summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorkyak2015-08-29 22:47:15 +0300
committerkyak2015-08-29 22:47:15 +0300
commit26d4bc5262e352f213249639a6c320ca214b6b5a (patch)
treeb538254afa2d94a2a0b8538c5292fc39ae93eaa0 /PKGBUILD
parentc761834d067893b2bb3ff377902e07394231fc18 (diff)
downloadaur-asus-kbd-backlight.tar.gz
Remove sudo and simplify systemd unit file
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 5 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 16ac811b8079..31e60fe1cb6b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Author: Stefan Majewsky <majewsky at-the-server gmx with-the-tld net>
pkgname=asus-kbd-backlight
-pkgver=1.1
+pkgver=1.2
pkgrel=1
pkgdesc="Helper for adjusting keyboard backlight brightness in Asus Zenbook UX31A and similar models"
url="https://wiki.archlinux.org/index.php/ASUS_Zenbook_Prime_UX31A#keyboard_backlight_script"
@@ -75,13 +75,13 @@ build() {
;;
allowusers)
# Allow members of users group to change brightness
- sudo chgrp users ${path}/brightness
- sudo chmod g+w ${path}/brightness
+ chgrp users ${path}/brightness
+ chmod g+w ${path}/brightness
;;
disallowusers)
# Allow members of users group to change brightness
- sudo chgrp root ${path}/brightness
- sudo chmod g-w ${path}/brightness
+ chgrp root ${path}/brightness
+ chmod g-w ${path}/brightness
;;
*)
commit $1
@@ -96,10 +96,7 @@ build() {
After=systemd-udevd.service
[Service]
- Type=oneshot
- RemainAfterExit=yes
ExecStart=/usr/bin/asus-kbd-backlight allowusers
- ExecStop=/usr/bin/asus-kbd-backlight disallowusers
[Install]
WantedBy=multi-user.target