summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVincent Grande2020-12-21 23:53:55 -0500
committerVincent Grande2020-12-21 23:53:55 -0500
commit3aaf0d2c045b5df0d146dfa9e4180537f03d3cb4 (patch)
treeb3616ca8e8c312440b51bb17f2f4eda1a9e7968c /PKGBUILD
downloadaur-3aaf0d2c045b5df0d146dfa9e4180537f03d3cb4.tar.gz
initial upload
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3310721592a9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Vincent Grande <shoober420@gmail.com>
+# Contributor: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
+# Contributor: Ionut Biru <ibiru@archlinux.org>
+
+pkgname=at-spi2-core-git
+pkgver=2.38.0
+pkgrel=1
+pkgdesc="Protocol definitions and daemon for D-Bus at-spi"
+url="https://gitlab.gnome.org/GNOME/at-spi2-core"
+arch=(x86_64)
+license=(GPL2)
+depends=(dbus glib2 libxtst)
+makedepends=(gobject-introspection git meson dbus-broker)
+optdepends=('dbus-broker: Alternative bus implementation')
+provides=(at-spi2-core)
+conflicts=(at-spi2-core)
+source=("git+https://gitlab.gnome.org/GNOME/at-spi2-core.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --tags | sed 's/^AT_SPI2_CORE_//;s/_/./g;s/-/+/g'
+ }
+
+prepare() {
+ cd $pkgname
+ }
+
+build() {
+ arch-meson $pkgname build \
+ -D default_bus=dbus-broker \
+ -D docs=false
+ meson compile -C build
+ }
+
+#check() {
+ # memory test fails without desktop
+ # broker fails to launch without journald
+# dbus-run-session meson test -C build --print-errorlogs || :
+# }
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+ }
+
+# vim:set ts=2 sw=2 et:
+