summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGeorge Rawlinson2020-06-11 20:02:42 +1200
committerGeorge Rawlinson2020-06-11 20:02:42 +1200
commit4657d2c3a3dd5a4a6b185b3085da2ddc6dbd1728 (patch)
tree0c412563492c5615c95bb41458d999159f1cf68f /PKGBUILD
parent4252a3eb1d0ccde7e7bbb8fd35740f8a3f5ddbdf (diff)
downloadaur-4657d2c3a3dd5a4a6b185b3085da2ddc6dbd1728.tar.gz
upgpkg: atom-editor-bin 1.48.0-1
This package is a monster, scarily intertwined with unstated dependencies and unknown arcane magic.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 3 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 89e7f0400cea..4917d4bc4b7a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
# Contributor: Danny Arnold <despair.blue at gmail dot com>
pkgname=atom-editor-bin
-pkgver=1.47.0
+pkgver=1.48.0
pkgrel=1
pkgdesc="Hackable text editor built on Electron (official precompiled binary)"
arch=('x86_64')
@@ -14,19 +14,17 @@ url="https://github.com/atom/atom"
license=('MIT')
provides=('atom' 'apm')
options=(!strip !emptydirs)
-depends=('git' 'gtk3' 'libnotify' 'libxtst' 'nss' 'python2' 'xdg-utils' 'desktop-file-utils' 'alsa-lib' 'libgnome-keyring' 'libxss' 'libxkbfile' 'ripgrep')
+depends=('git' 'gtk3' 'libnotify' 'libxtst' 'nss' 'xdg-utils' 'desktop-file-utils' 'alsa-lib' 'libgnome-keyring' 'libxss' 'libxkbfile' 'ripgrep')
optdepends=('gvfs')
conflicts=('atom' 'atom-editor' 'atom-editor-git' 'atom-editor-git-tagged' 'apm' 'atom-notracking')
install=$pkgname.install
source=("atom-amd64-v${pkgver}.deb::https://atom-installer.github.com/v${pkgver}/atom-amd64.deb"
"LICENSE::https://raw.githubusercontent.com/atom/atom/v${pkgver}/LICENSE.md"
atom-editor-bin.install
- atom-python.patch
startupwmclass.patch)
-sha512sums=('ee5cc42a597cba015f1144fda8cad882e4cecc7c417c1cf69078a2b74b64d2e222a8422611b70e6c4327b51f8d28a449b1109558c3f4fa728f19db4618318095'
+sha512sums=('d45080877302840a375af1c4e6f7e74b71fdf6bc209f5217fde60afa7594b678e149b6f99f19a8f2b6aab7cd6c79b5a6740f0a2a023a6c6e97145c7c770a68ad'
'c8fdd1d51313c078d20ab4c127db78d71d94e1987b78ce04fb1b6b47e875b047c5722092892ac0b6ec6640c7428b4e03a22f71f29d9d67082cd22cadf604b7fc'
'e30f7e4812898b80c079ba419e0cb37522c2e154ef7fdd6dda3da06dcbcaadc42016dd3d3b8caf206b842a2b9e3b954e537626d72337c56f05365a733627ce6c'
- '37e33402ff1a21c27debc56ac909279992c6a3aa9f2d8dd49fb13fc02cc3fb91a373531be92df9cc81089e167827ca7b36f967e4f7e482b1173d358a8b29cb98'
'374b9f8fa1e0d2cab77d4cea9c718fb889bb6db3dbf9762ad5cbb88f3a0936023f36641012fc90e029832a772b8d4fdfe6b72f304e3950c02a7c9bf4d6d3d4ec')
prepare() {
@@ -34,12 +32,7 @@ prepare() {
bsdtar xf data.tar.xz
# Apply patches
- patch -sp1 < "${srcdir}"/atom-python.patch
patch -sp1 < "${srcdir}"/startupwmclass.patch
-
- # Modify package to use python2 instead of python3
- sed -i 's|env PYTHON=python2 GTK_IM_MODULE= QT_IM_MODULE= XMODIFIERS= /usr/share/atom/atom|/usr/bin/atom|' usr/share/applications/atom.desktop
- sed -i 's|python|python2|' usr/share/atom/resources/app/apm/bin/python-interceptor.sh
}
package() {