summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavid Barri2021-02-17 12:29:10 +1100
committerDavid Barri2021-02-17 12:29:10 +1100
commit93f5853e761b33ce0bb271da17e825119236e130 (patch)
tree3516efcad310817804a7eb19f21eb02449f28cf8 /PKGBUILD
parentb5e18395d919f81f9e50cf9409d26d1747627e76 (diff)
downloadaur-93f5853e761b33ce0bb271da17e825119236e130.tar.gz
Use rpm instead of appimage
* Starts much faster * Integrates with desktop app menus
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a84f0665e1e6..28ea2da3f737 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,12 +6,17 @@ pkgdesc="Atomic Wallet is a decentralized Cryptocurrency wallet that supports mo
arch=('x86_64')
url="https://atomicwallet.io"
license=('unknown')
-source=("https://get.atomicwallet.io/download/atomicwallet-$pkgver-116.AppImage")
-sha256sums=('ff649f16dcf9fffd5da8832b564bdc219f7959277f3673c443e6d5c3331b643f')
-options=('!strip')
+source=("https://get.atomicwallet.io/download/atomicwallet-$pkgver-116.rpm")
+sha256sums=('4e6e3aabe764b28cdc2edc08ef83e3c60c5fe13054699eed8cc0bea8fb58c13c')
+makedepends=('rpmextract')
package() {
- set -eu
+ set -e
- install -Dm755 atomicwallet-$pkgver-*.AppImage "$pkgdir/usr/bin/atomicwallet"
+ mv opt usr "$pkgdir"
+
+ cd "$pkgdir/usr"
+ mkdir bin
+ cd bin
+ ln -s "../../opt/Atomic Wallet/atomic" atomicwallet
}