summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKlaus Alexander Seistrup2021-10-06 07:21:41 +0200
committerKlaus Alexander Seistrup2021-10-06 07:21:41 +0200
commit56a26b179cc25ce6a369ea0c5b78096be5e25b78 (patch)
tree890a1376e6594b5ccf0f90b7275663f8327251a0 /PKGBUILD
parenta7a4dc71e6153fc7cdf47b24315757dbf3dab057 (diff)
downloadaur-56a26b179cc25ce6a369ea0c5b78096be5e25b78.tar.gz
atto-1.3.0-2: also build atto-safesign
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5e3b9dbc1b0e..95d8478e1cb6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=atto
pkgver=1.3.0
-pkgrel=1
+pkgrel=2
pkgdesc='A tiny Nano wallet, focused on ease of use through simplicity'
arch=('x86_64')
url='https://github.com/codesoap/atto'
@@ -42,14 +42,16 @@ build() {
export GOFLAGS='-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw'
go build ./cmd/atto
+ go build ./cmd/atto-safesign
}
package() {
cd "$pkgname-$pkgver" || exit 1
- install -Dm0755 atto "$pkgdir/usr/bin/atto"
- install -Dm0644 README.md "$pkgdir/usr/share/doc/$pkgname/README.md"
- install -Dm0644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm0755 atto "$pkgdir/usr/bin/atto"
+ install -Dm0755 atto-safesign "$pkgdir/usr/bin/atto-safesign"
+ install -Dm0644 README.md "$pkgdir/usr/share/doc/$pkgname/README.md"
+ install -Dm0644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
# eof