summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEllie Huxtable2021-02-14 23:24:09 +0000
committerEllie Huxtable2021-02-14 23:24:09 +0000
commitc7b7284621cf3cfa026be623d1380eb323f9cafc (patch)
tree8055b801ab7a2b3854bf8e6397c388aa37cc426b /PKGBUILD
downloadaur-c7b7284621cf3cfa026be623d1380eb323f9cafc.tar.gz
Initial package release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 17 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..89a3bc4eaad7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Ellie Huxtable <e@elm.sh>
+pkgname=atuin
+pkgver=0.3.1
+pkgrel=1
+makedepends=('rustup')
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+pkgdesc="atuin - magical shell history"
+license=('MIT')
+
+build() {
+ return 0
+}
+
+package() {
+ rustup default nightly
+ cargo install --no-track --locked --all-features --root "$pkgdir/usr/" --version $pkgver --path . atuin
+}