summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBitts3112020-06-07 11:55:31 +0300
committerBitts3112020-06-07 11:55:31 +0300
commit162eca92f79ae77f5e688e5039da0aba744a996a (patch)
tree61914feedf1bcb24ac65fe2feee824278b16b459 /PKGBUILD
downloadaur-162eca92f79ae77f5e688e5039da0aba744a996a.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..a51ea0811972
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+## To enable GTK support, uncomment the additional dependency and "--enable-gtk".
+## Do the same with audacious-plugins-git. Then run Audacious by "audacious --gtk".
+
+_pkgname=audacious-plugins
+pkgname=$_pkgname-gtk
+pkgver=4.0.4
+pkgrel=1
+pkgdesc="Plugins for Audacious"
+arch=('x86_64')
+url="https://audacious-media-player.org/"
+license=('BSD' 'GPL')
+provides=('audacious-plugins')
+conflicts=('audacious-plugins')
+depends=('audacious' 'glib2' 'alsa-lib' 'pulseaudio' 'jack2' 'lame' 'libvorbis' 'flac' 'mpg123' 'faad2' 'ffmpeg' 'libmodplug' 'fluidsynth' 'libcdio-paranoia' 'libsidplayfp' 'wavpack' 'dbus-glib' 'libsamplerate' 'libnotify' 'lirc' 'curl' 'libmtp' 'neon' 'libmms' 'libcue')
+source=("https://distfiles.audacious-media-player.org/audacious-plugins-4.0.4.tar.bz2")
+sha256sums=('SKIP')
+
+prepare() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ autoreconf -I m4
+}
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ ./configure \
+ --prefix=/usr \
+ --enable-gtk \
+
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+}
+