summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorYannick Le Guen2015-06-09 19:31:51 +0200
committerYannick Le Guen2015-06-09 19:31:51 +0200
commit6da19985aa5c408a0b88ece388ef63ef9b21a02e (patch)
tree9a71d322350250f8ccbbfdcf545c619b680393e7 /PKGBUILD
parent376e0303ceb0863068d7330acde79e12ea9450e5 (diff)
downloadaur-6da19985aa5c408a0b88ece388ef63ef9b21a02e.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 18 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 15c05586d680..ee3bf31854fe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
# Maintainer: Spike29 <leguen.yannick@gmail.com>
+# Contributor: goetzc <goetzchrist@gmail.com>
# Contributor: Lucas SaliƩs Brum <lucas@archlinux.com.br>
-
+
pkgname=audio-recorder
pkgver=1.6.3
pkgrel=1
@@ -11,21 +12,30 @@ license=('GPL3')
depends=('gst-plugins-base' 'gtk3' 'libappindicator-gtk3')
makedepends=('intltool')
optdepends=('pulseaudio: for extended recording capabilities'
- 'gst-plugins-good: for WAV and Flac encoding'
- 'gst-plugins-bad: for AAC encoding'
- 'gst-plugins-ugly: for MP3 encoding')
+ 'gst-plugins-good: for WAV and Flac encoding'
+ 'gst-plugins-bad: for AAC encoding'
+ 'gst-plugins-ugly: for MP3 encoding')
provides=('audio-recorder')
install="$pkgname.install"
conflicts=('audio-recorder-bzr' 'audio-recorder-from-deb')
-source=("https://launchpad.net/~osmoma/+archive/ubuntu/${pkgname}/+files/${pkgname}_1.6-3%7Evivid.tar.gz")
-md5sums=('bf01da5442b03ac39d950a238b556f93')
-
+source=("https://launchpad.net/~osmoma/+archive/ubuntu/${pkgname}/+files/${pkgname}_1.6-3%7Evivid.tar.gz"
+ "fix_gtk3.16_build.patch")
+md5sums=('bf01da5442b03ac39d950a238b556f93'
+ '84edc83c85c82903070401274b22803c')
+
+prepare() {
+ cd "$srcdir/$pkgname"
+ # Fix build with GTK 3.16
+ # https://bugs.launchpad.net/audio-recorder/+bug/1442219
+ patch -p1 < ../fix_gtk3.16_build.patch
+}
+
build() {
cd "$srcdir/$pkgname"
./configure --prefix=/usr
make
}
-
+
package() {
cd "$srcdir/$pkgname"
make DESTDIR="$pkgdir/" install