summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBronson2018-04-11 11:23:35 +0930
committerBronson2018-04-11 11:23:35 +0930
commit5cb28e8772a0e9a1e8b467afa825c7804501eabe (patch)
treeb7f6583abb2fc45893b009cad69906c7dce93a79 /PKGBUILD
downloadaur-5cb28e8772a0e9a1e8b467afa825c7804501eabe.tar.gz
initial
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d181617b82a5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: bronson mathews <bronsonmathews@gmail.com> -> http://bit-shift.io -> https://github.com/bit-shift-io
+pkgname=audiobook-git
+pkgver=r20.a829f6f
+pkgrel=1
+pkgdesc="A simple audio book reader. Written in Qt and C++."
+arch=('x86_64')
+url="https://github.com/bit-shift-io/audiobook"
+license=('GPL3')
+depends=('qt5-base')
+makedepends=('git' 'qt5-tools' 'qt5-multimedia' 'taglib')
+provides=('audiobook')
+source=("${pkgname}::git+https://github.com/bit-shift-io/audiobook.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${pkgname}"
+ mkdir -p build
+ cd "${srcdir}/${pkgname}/build"
+ qmake ../audiobook.pro -r CONFIG+=release PREFIX=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}/build"
+ make install INSTALL_ROOT="${pkgdir}/"
+}