summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Arndt2017-05-05 13:37:11 +0200
committerChristopher Arndt2017-05-05 13:37:11 +0200
commit1013ebe6fb906df005d6be19a06fd3815aba3b8c (patch)
tree24795bb7c394d972c7093a5d3d6be4c27a1245ae /PKGBUILD
parentd49c17559b118d253f91665137ee0d962edec1df (diff)
downloadaur-1013ebe6fb906df005d6be19a06fd3815aba3b8c.tar.gz
Fix docs building and version number detection
Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 18 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 79ef12c803d3..aa50caeb6530 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=audiotk
pkgname="${_pkgname}-git"
-pkgver=1.2.0.r808.0af35fc
+pkgver=2.0.2.r1502.305ee21
pkgrel=1
pkgdesc="A C++ library plus Python 3 bindings with a set of audio filters (git version)"
arch=('i686' 'x86_64')
@@ -10,17 +10,19 @@ license=('BSD')
url='https://github.com/mbrucher/AudioTK'
depends=('fftw' 'libsndfile' 'python')
makedepends=('git' 'cmake')
-source=("${_pkgname}::git+https://github.com/mbrucher/AudioTK.git")
+source=("${_pkgname}::git+https://github.com/mbrucher/AudioTK.git"
+ 'audiotk-cmakelists.diff')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
-md5sums=('SKIP')
+md5sums=('SKIP'
+ '9ba195731f5d64b58e668639b7e0bfe8')
pkgver() {
cd "${srcdir}/${_pkgname}"
- version="$(git describe --tags | sed -e 's/^[^-]*-//;s/-.*//')"
- revision=$(git rev-list --count HEAD)
- hash=$(git rev-parse --short HEAD)
+ local version="$(grep ^PROJECT_NUMBER Doxyfile | awk '{ print $3 }')"
+ local revision=$(git rev-list --count HEAD)
+ local hash=$(git rev-parse --short HEAD)
echo $version.r$revision.$hash
}
@@ -33,6 +35,7 @@ prepare() {
mkdir build
git checkout develop
+ patch -p1 -i "${srcdir}/audiotk-cmakelists.diff"
}
build() {
@@ -45,8 +48,15 @@ build() {
-DCMAKE_INSTALL_PREFIX=/usr \
-DENABLE_PYTHON=1 \
-DPYTHON_INSTALL_FOLDER=/usr/lib/python${py_ver} \
- -DENABLE_TESTS=1
- make DESTDIR="${pkgdir}"
+ -DENABLE_TESTS=1 \
+ -DBUILD_DOC=1
+ make
+}
+
+check() {
+ cd "${srcdir}/${_pkgname}/build"
+
+ make test
}
package() {