summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhilipp A2019-03-11 18:41:43 +0100
committerPhilipp A2019-03-11 18:41:43 +0100
commitfbb93d6def8ff66ed539af31c21a73d87c6d8c39 (patch)
treeacca1c6c45995087219a9e390928379204172e27 /PKGBUILD
parent48a4e27bd9ff7281bd615152f81834c6b4524757 (diff)
downloadaur-fbb93d6def8ff66ed539af31c21a73d87c6d8c39.tar.gz
install-wheel-scripts
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 3 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9eb5e9bff515..df572a0e015f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,13 @@
pkgname=auditwheel
pkgver=2.0.0
-pkgrel=2
+pkgrel=3
pkgdesc='Cross-distribution Linux wheels'
arch=(any)
url="https://github.com/pypa/auditwheel"
license=(MIT)
depends=(python-wheel python-pyelftools)
+makedepends=(install-wheel-scripts)
_pyarch=py3
_wheel="$pkgname-$pkgver-$_pyarch-none-any.whl"
source=("https://files.pythonhosted.org/packages/$_pyarch/${pkgname::1}/$pkgname/$_wheel")
@@ -18,11 +19,5 @@ package() {
local site="$pkgdir/usr/lib/$(readlink /bin/python3)/site-packages"
mkdir -p "$site"
unzip "$_wheel" -d "$site"
-
- cat >auditwheel.py <<-EOF
- #!/usr/bin/env python3
- from auditwheel.main import main
- main()
- EOF
- install -Dm755 auditwheel.py "$pkgdir/usr/bin/auditwheel"
+ install-wheel-scripts --prefix="$pkgdir/usr" "$_wheel"
}