summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormschubert2015-06-12 12:07:38 +0100
committermschubert2015-06-12 12:07:38 +0100
commit0d40ece0f10dcd74c0f360a816a7e7b1e1eaba4e (patch)
tree20c9a570b8594d48dc95d8ed75ab7deac5ae0c1f /PKGBUILD
downloadaur-0d40ece0f10dcd74c0f360a816a7e7b1e1eaba4e.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..92b7a09773b4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Michael Schubert <mschu.dev at google mail>
+pkgname=augustus
+pkgver=2.5.5
+pkgrel=1
+pkgdesc="A eucaryotic gene prediction program"
+arch=('i686' 'x86_64')
+url="http://augustus.gobics.de/"
+license=('custom:Artistic-2.0')
+depends=('perl')
+source=("http://augustus.gobics.de/binaries/$pkgname.$pkgver.tar.gz"
+ "http://augustus.gobics.de/binaries/LICENCE.TXT")
+md5sums=('234adc8fe4c2ff0b70715fbf00173668'
+ '7e2216d2af60d1644c220cbad40b0e36')
+options=(!strip)
+
+build() {
+ cd $pkgname.$pkgver
+ make all
+}
+
+package() {
+ cd $pkgname.$pkgver
+
+ mkdir -p "$pkgdir/usr/share/augustus/scripts"
+ mkdir -p "$pkgdir/etc/"{augustus,profile.d}
+
+ cp -R bin "$pkgdir/usr/"
+ cp -R config "$pkgdir/etc/augustus/"
+ cp -R {docs,examples} "$pkgdir/usr/share/augustus/"
+ cp scripts/*.pl "$pkgdir/usr/share/augustus/scripts/"
+
+ echo export AUGUSTUS_CONFIG_PATH="/etc/augustus/config/" > "$pkgdir/etc/profile.d/augustus.sh"
+ chmod a+rx "$pkgdir/etc/profile.d/augustus.sh"
+
+ install -Dm644 "$srcdir/LICENCE.TXT" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+