summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStephan Springer2018-09-10 17:52:11 +0200
committerStephan Springer2018-09-10 17:52:11 +0200
commit7b072669ead52ee57b175286387a1f366d93ee96 (patch)
tree97e318983df7582a561ffe13747cc216816ecc81 /PKGBUILD
downloadaur-7b072669ead52ee57b175286387a1f366d93ee96.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5378bedd62c4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Stephan Springer <buzo+arch@Lini.de>
+
+_pkgname=aurblobs
+pkgname="$_pkgname-git"
+pkgver=r80.2dfcc20
+pkgrel=1
+pkgdesc='Automatically build AUR packages and serve them from a repository (git version)'
+arch=('any')
+url='https://github.com/aurblobs/aurblobs'
+license=('AGPL3')
+makedepends=('git' 'python-setuptools')
+depends=('python-click' 'python-docker' 'python-gitpython' 'git'
+ 'python-pretty_bad_protocol' 'python-xdg')
+source=("git+https://github.com/$_pkgname/$_pkgname.git"
+ 'fix-constants.diff')
+sha256sums=('SKIP' 'SKIP')
+
+pkgver() {
+ cd "$_pkgname/"
+ printf "r%s.%s" \
+ "$(git rev-list --count HEAD)" \
+ "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$_pkgname/"
+ patch -p2 -i "$srcdir"/fix-constants.diff
+}
+
+build() {
+ cd "$_pkgname"
+ python setup.py build
+}
+
+package() {
+ cd "$_pkgname"
+ python setup.py install --root="$pkgdir" --optimize=1
+}