summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsekret2016-02-08 22:18:51 +0100
committersekret2016-02-08 22:18:51 +0100
commitaa9fb8b4ba4b4ff54c104b6d083f17b9c3afe40b (patch)
treed9c067d4751a663e1a9a0dcc2b6ce54265cb676b /PKGBUILD
downloadaurebuildcheck-git.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5b28abd8915c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: sekret, mail=$(echo c2VrcmV0QHBvc3Rlby5zZQo= | base64 -d)
+_pkgname=aurebuildcheck
+pkgname=$_pkgname-git
+pkgver=2.5.r30.gdbcfaa7
+pkgrel=1
+pkgdesc="Shell script which checks for aur (local) packages which need rebuild according to findbrokenpkgs"
+arch=('any')
+url="https://github.com/matthiaskrgr/aurebuildcheck"
+license=('GPL')
+makedepends=('git')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("$_pkgname::git+$url.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$_pkgname"
+ install -Dm755 $_pkgname.sh "$pkgdir/usr/bin/$_pkgname"
+}
+
+# vim:set ts=2 sw=2 et: