summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorXZS2016-02-07 23:22:09 +0100
committerXZS2016-02-07 23:27:32 +0100
commite3279f70de910d9bb23c3d8c823b6c9cb72585f9 (patch)
tree332c984bc0fb75c9cc1c72a0a26ea382565d135d /PKGBUILD
parentefbd794a08527644e08484c71ce0358569f4fc0f (diff)
downloadaur-e3279f70de910d9bb23c3d8c823b6c9cb72585f9.tar.gz
attempt to fix ever-changing checksum
The checksum of the source archive often changes without any evident modification of its content. At the moment, I can only speculate about why that happens. Perhaps Dropbox compresses the files on the fly changing the checksum of the archive, but not the contents, whenever some detail of the compression process changes. Fortunately, bsdtar can re-compressing archives as part of a pipe. This way, it can be inserted as a DLAGENT so that it does its work before makepkg computes the checksum.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 10 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1731d99b44e7..1d2f40c70ec8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,16 @@ url="http://opendesktop.org/content/show.php?content=170523"
license=('GPL3')
optdepends=("gtk-engine-murrine: for GTK2 themes")
source=("${pkgname}.tar.gz::https://www.dropbox.com/s/4ik0pbbpsiqe4ci/Aurora-${pkgver%.*}.tar.gz?dl=1")
-sha256sums=('28fc4b3ba2e70ee6e7fe6d1e4785be4e9f4064dae58440f02e077752c7a6e780')
+sha256sums=('b47691e1effb39ba85baa88e161fab8ae3c7e3baafd303d3b2f77e0ebb63750f')
+
+# The archive downloaded from Dropbox seems to change its hash without any
+# evident content change. This could originate from the compression of these
+# files on the fly, so recompressing it is an attempt to stabilize the checksum
+# only dependent on the actual contents.
+DLAGENTS=("https::/usr/bin/bash -c $(
+ printf '%s\n' "${DLAGENTS[@]}" | sed -n 's/https::\(.*\)/\1/p' \
+ | sed 's/-[^ ] %o //' | sed 's/ /\\ /g'
+)\ |\ bsdtar\ -caf\ %o\ @-")
pkgver() {
dir="$(echo Aurora-*)"