summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuís Ferreira2018-08-23 00:49:17 +0100
committerLuís Ferreira2018-08-23 00:49:17 +0100
commit5d086eb53499bad9af68d3d93651de66f8530ad6 (patch)
treead63160cf6373b10bcc5a8cfb8fdaeff66fbffca /PKGBUILD
downloadaur-5d086eb53499bad9af68d3d93651de66f8530ad6.tar.gz
init package
Signed-off-by: Luís Ferreira <contact@lsferreira.net>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1ad6fc1c592d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Luís Ferreira <contact@lsferreira.net>
+
+pkgname=aurorafw-git
+pkgver=r62.7a2733e
+pkgrel=1
+pkgdesc="A Powerful General Purpose Framework"
+arch=('any')
+url="https://gitlab.com/aurorafossorg/p/framework/core"
+license=('GNU LGPLv3')
+provides=('aurorafw')
+conflicts=('aurorafw')
+depends=('glfw' 'vulkan-headers' 'opengl-driver' 'libx11' 'freeimage' 'portaudio' 'libsndfile')
+makedepends=('doxygen' 'meson' 'ninja')
+source=('git+https://gitlab.com/aurorafossorg/p/framework/core.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/core"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ meson --buildtype=release . .build
+ pushd .build
+ ninja
+ ninja install
+ popd
+}
+