summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFFY002018-08-23 01:47:50 +0100
committerFFY002018-08-23 01:47:50 +0100
commitf307b04762c7e7e61b8ec02be4055c67c0eda47e (patch)
treeb91081593e48579b7d49df0f91c5fc96c45cc78a /PKGBUILD
parent31366bc2291067ee82faa9122b8dc2955b0b50ed (diff)
downloadaur-f307b04762c7e7e61b8ec02be4055c67c0eda47e.tar.gz
pkgbuild: fix everything :/
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD51
1 files changed, 34 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4584c1949e2c..cd3cfedeb890 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,48 @@
# Maintainer: Luís Ferreira <contact@lsferreira.net>
+# Maintainer: Filipe Laíns (FFY00) <lains@archlinux.org>
pkgname=aurorafw-git
-pkgver=r62.7a2733e
-pkgrel=3
+_gitname=core
+pkgver=0.0.1.alpha.2.r27.914cf66
+pkgrel=1
pkgdesc="A Powerful General Purpose Framework"
-arch=('any')
+arch=('x86_64' 'i686')
url="https://gitlab.com/aurorafossorg/p/framework/core"
-license=('GNU LGPLv3')
+license=('LGPL3')
provides=('aurorafw')
conflicts=('aurorafw')
-depends=('glfw' 'vulkan-headers' 'opengl-driver' 'libx11' 'freeimage' 'portaudio' 'libsndfile' 'glew' 'gtk3')
-makedepends=('doxygen' 'meson' 'ninja' 'pkgconf')
-source=('git+https://gitlab.com/aurorafossorg/p/framework/core.git')
-sha256sums=('SKIP')
+depends=('glfw' 'opengl-driver' 'libx11' 'freeimage' 'portaudio' 'libsndfile' 'glew' 'gtk3' 'vulkan-icd-loader')
+makedepends=('git' 'doxygen' 'meson' 'vulkan-headers' 'ldc')
+source=("$pkgname-$_gitname::git+https://gitlab.com/aurorafossorg/p/framework/core.git")
+sha512sums=('SKIP')
pkgver() {
- cd "$srcdir/core"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd $pkgname-$_gitname
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g;s/\.rc./rc/g'
}
-package() {
- pushd "$srcdir/core"
- meson --buildtype=release . .build
- pushd .build
+build() {
+ mkdir -p $pkgname-$_gitname/build
+ cd $pkgname-$_gitname/build
+
+ export DC=ldmd
+
+ #arch-meson ..
+ meson --prefix=/usr ..
+
ninja
- ninja install
- popd
- popd
+}
+
+check() {
+ cd $pkgname-$_gitname/build
+
+ meson test
+}
+
+package() {
+ cd $pkgname-$_gitname/build
+
+ DESTDIR="$pkgdir" ninja install
}