summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlad Wenter2016-05-02 09:47:59 +0200
committerAlad Wenter2016-05-02 09:47:59 +0200
commit4ca8a2501f6cb990801c4005a8ae9f343c43407e (patch)
treeabdd22c51c46c89f59b4b2bd727a428c295a5d0f /PKGBUILD
parent5baf494029ca9240d7de18830922ca5bdff7c3f8 (diff)
downloadaur-4ca8a2501f6cb990801c4005a8ae9f343c43407e.tar.gz
no makefile yet
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c2c75f02c74b..f8425d7b8b1c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,10 +16,16 @@ optdepends=('devtools: build in an nspawn container'
check() {
cd "$pkgname-$pkgver"
- make check
+ LANG=C shellcheck -e 2016 -x bin/*
}
package() {
cd "$pkgname-$pkgver"
- make DESTDIR="$pkgdir/" install
+ install -d "$pkgdir"/usr/{bin,share{/zsh/site-functions,/man/man1,{/licenses,/doc}/aurutils}}
+
+ install -m755 bin/* "$pkgdir"/usr/bin/
+ install -m644 completions/* "$pkgdir"/usr/share/zsh/site-functions/
+ install -m644 doc/* "$pkgdir"/usr/share/man/man1/
+ install -m644 LICENSE "$pkgdir"/usr/share/licenses/aurutils/
+ install -m644 CREDITS README "$pkgdir"/usr/share/doc/aurutils/
}