summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlad Wenter2023-06-05 22:40:29 +0200
committerAlad Wenter2023-06-05 22:40:29 +0200
commit754851b48b041cf6267a2d7bab1e8dab6dcaa147 (patch)
tree1686af6c1a67e83c765323c07a3b6b279c2fa6da /PKGBUILD
parent62eb087b20174de44880184ae897e7d34776b5ad (diff)
downloadaur-754851b48b041cf6267a2d7bab1e8dab6dcaa147.tar.gz
add PREFIX, ETCPATH
This avoids issues when the environment inadvertently sets these variables. https://bbs.archlinux.org/viewtopic.php?pid=2103515#p2103515
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index be4919508c0b..d4232f7b75f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Co-Maintainer: Cedric Girard <cgirard [dot] archlinux [at] valinor [dot] fr>
pkgname=aurutils
pkgver=15.5
-pkgrel=1
+pkgrel=2
pkgdesc='helper tools for the arch user repository'
url='https://github.com/AladW/aurutils'
arch=('any')
@@ -11,7 +11,7 @@ source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/$pkgver.tar.gz")
changelog=aurutils.changelog
install=aurutils.install
sha256sums=('f7a2bd5ac72860588e8dce62929c8d905ec1eab502a1b1308da1e48c91df8142')
-depends=('git' 'pacutils' 'curl' 'perl')
+depends=('git' 'pacutils' 'curl' 'perl' 'bash')
optdepends=('bash-completion: bash completion'
'zsh: zsh completion'
'devtools: aur-chroot'
@@ -30,5 +30,5 @@ build() {
package() {
cd "$pkgname-$pkgver"
- make DESTDIR="$pkgdir" install
+ make PREFIX=/usr ETCDIR=/etc DESTDIR="$pkgdir" install
}