summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlad Wenter2016-03-26 20:17:11 +0100
committerAlad Wenter2016-03-26 20:17:11 +0100
commita40161cf87b288fbff03e54b7a9b71f337366cf4 (patch)
tree4908762fbc42a571a27ef3a8d551a6a7feefdf33 /PKGBUILD
downloadaur-a40161cf87b288fbff03e54b7a9b71f337366cf4.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e38800b5a034
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+pkgname=aurutils
+pkgver=0.1.0
+pkgrel=1
+pkgdesc='helper tools for the aur'
+arch=('any')
+url='https://github.com/AladW/aurutils'
+license=('ISC')
+source=("$url/archive/0.1.0.tar.gz")
+depends=('pacman>=5.0' 'git' 'repose' 'jshon' 'pacutils' 'expac' 'aria2')
+checkdepends=('shellcheck')
+makedepends=('git')
+optdepends=('devtools: aurbuild -c'
+ 'vifm: improved build file interaction')
+
+check() {
+ cd aurutils
+ shellcheck -e 2016,2174 -x ./aur* repofind
+}
+
+package() {
+ cd aurutils
+ install -d "$pkgdir"/usr/{bin,share{/licenses,/doc}/aurutils}
+
+ install -m755 ./aur* repofind "$pkgdir"/usr/bin/
+ install -m644 LICENSE "$pkgdir"/usr/share/licenses/aurutils/
+ install -m644 CREDITS doc/* "$pkgdir"/usr/share/doc/aurutils/
+}
+
+md5sums=('5e1274effc335aa81d06696d47ad0df2')