summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEmmanuel Gil Peyrot2021-03-17 20:33:10 +0100
committerEmmanuel Gil Peyrot2021-03-17 20:33:10 +0100
commit8bd6d6cd9915f2ec8d8c23951c2cc9e612da825f (patch)
tree94cd8fe78454fe9f664ec70e5ffaa5e55326aa90 /PKGBUILD
downloadaur-austin-git.tar.gz
Hello world!
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1926e6c68839
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Emmanuel Gil Peyrot <linkmauve@linkmauve.fr>
+
+pkgname=austin-git
+pkgver=v2.1.1.r0.g2f29bd7
+pkgrel=1
+pkgdesc='Python frame stack sampler for CPython'
+arch=('x86_64' 'armv7h' 'aarch64')
+url='https://github.com/P403n1x87/austin'
+license=('GPL3')
+makedepends=('git')
+conflicts=('austin')
+provides=("austin")
+
+source=('git+https://github.com/P403n1x87/austin')
+sha1sums=('SKIP')
+
+pkgver() {
+ cd austin
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd austin
+ autoreconf --install
+ mkdir build
+}
+
+build() {
+ cd austin/build
+ ../configure --prefix=/usr
+ make
+}
+
+package() {
+ cd austin/build
+ make DESTDIR="$pkgdir" install
+}