summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexander F Rødseth2016-01-09 14:08:15 +0100
committerAlexander F Rødseth2016-01-09 14:08:15 +0100
commitf31ae5bdfd547d39732ac2e90aae672727c1990d (patch)
treecd19ef6a3e5b5afba57ba435b7d33c8c1986a25e /PKGBUILD
parent9397fa43281d01308ca6449a9071b8c79077aa51 (diff)
downloadaur-f31ae5bdfd547d39732ac2e90aae672727c1990d.tar.gz
Upgrade to 3.3.14.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 11 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 063b4f4b6118..893c9add0394 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,28 @@
-# Maintainer: Alexander Rødseth <rodseth@gmail.com>
+# Maintainer: Alexander F Rødseth <xyproto@archlinux.org>
pkgname=aut2exe
-pkgver=3.3.6.1
-pkgrel=3
-pkgdesc="AutoIt compiler (from au3 to exe)"
+pkgver=3.3.14.0
+pkgrel=1
+pkgdesc='AutoIt compiler'
arch=('any')
-url="http://www.autoitscript.com/"
+url='http://www.autoitscript.com/'
license=('custom')
depends=('wine')
-makedepends=('p7zip')
optdepends=('aut2exe-docs: help files and sample code')
-md5sums=('a285f2a980d258fc1f095d12ada885e3'
- '1bc07254a7e54c7e91d8340b87860270'
- '4b9636dd42c12a66b586da8daf25c20c')
-source=("http://www.autoitscript.com/cgi-bin/getfile.pl?autoit3/autoit-v3-sfx.exe"
+source=("https://www.autoitscript.com/cgi-bin/getfile.pl?autoit3/autoit-v3.zip"
"http://www.autoitscript.com/autoit3/docs/license.htm"
"aut2exe.sh")
-
-build() {
- cd "$srcdir"
-
- msg2 "Extracting..."
- 7z x autoit-v3-sfx.exe > /dev/null
- mv install "$pkgname"
-}
+md5sums=('dd05a73ea361037181ad28aeb692647f'
+ '4aac1e01ecb674855ac3cf9eda0abda9'
+ '4b9636dd42c12a66b586da8daf25c20c')
package() {
- cd "$srcdir/$pkgname/Aut2Exe"
+ cd install/Aut2Exe
- msg2 "Packaging executables..."
install -Dm644 Aut2exe.exe "$pkgdir/usr/bin/Aut2exe.exe"
- install -Dm644 AutoItSC.bin "$pkgdir/usr/bin/AutoItSC.bin"
install -Dm644 upx.exe "$pkgdir/usr/bin/upx.exe"
install -Dm755 "$srcdir/aut2exe.sh" "$pkgdir/usr/bin/aut2exe"
-
- msg2 "Packaging license..."
install -Dm644 "$srcdir/license.htm" \
"$pkgdir/usr/share/licenses/$pkgname/license.html"
}
+
# vim:set ts=2 sw=2 et: