summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJan Cholasta2017-05-09 11:49:49 +0200
committerJan Cholasta2017-05-09 12:06:38 +0200
commit86f22b6f161cc12a9524a74b212578c8f488d03c (patch)
tree55ca2b2e68c7f32d8b9ee950e1b1211eb41ddf89 /PKGBUILD
parentc6c2d053ac1831f0e10a364f2fbb7b003aa32082 (diff)
downloadaur-86f22b6f161cc12a9524a74b212578c8f488d03c.tar.gz
authconfig-7.0.0-1
* base on upstream authconfig.spec
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD126
1 files changed, 25 insertions, 101 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3a9cf82f4be3..eb5f77f4ff3a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,29 @@
# Maintainer: Jan Cholasta <grubber at grubber cz>
# Contributor: François Steinmetz <francois.steinmetz@gmail.com>
# Contributor: Zdenek Janecek <jan.zdenek@gmail.com>
-# Based on Fedora authconfig.spec
-pkgname=(authconfig authconfig-gtk)
-pkgver=6.2.10
+pkgname=authconfig
+pkgver=7.0.0
pkgrel=1
pkgdesc='Command line tool for setting up authentication from network services'
arch=('i686' 'x86_64')
-url='https://fedorahosted.org/authconfig/'
+url='https://pagure.io/authconfig'
license=('GPL')
-depends=('libnewt' 'libpwquality' 'openssl' 'pam>=0.99.10.0' 'sssd>=1.13.0')
-makedepends=('desktop-file-utils'
- 'intltool'
- 'perl-xml-parser'
- 'python2')
+depends=('libpwquality' 'openssl' 'pam>=0.99.10.0' 'sssd>=1.13.0')
+makedepends=('intltool' 'python')
conflicts=('freeipa-client<2.2.0' 'nss_ldap<254' 'pam-krb5<1.49' 'samba<3.0')
+replaces=('authconfig-gtk')
backup=(etc/conf.d/authconfig
etc/pam.d/system-auth-ac
etc/pam.d/system-login-ac)
-source=("https://fedorahosted.org/releases/a/u/authconfig/${pkgname}-${pkgver}.tar.bz2"
+options=(emptydirs)
+source=("https://releases.pagure.org/${pkgname}/${pkgname}-${pkgver}.tar.bz2"
0001-Adapt-to-Arch-Linux.patch)
-sha256sums=('b9897f526825107287687084bd414c565a42b23e1669df0bf1a82cc460d3b78f'
- 'bbecf678693b96489239b37236846ba1a8058285fdf68f47d674b534137ee119')
+sha256sums=('60dfec18ba18bae38dc84aa2f8a2a7e5ca6b4eaf59a01c9acfbdfe66ca5a883f'
+ 'e29e810aea0bdaaafde7350399c12018bb5a316f1258fe264e8db6ef57155602')
prepare() {
- cd "${pkgbase}-${pkgver}"
+ cd "${pkgname}-${pkgver}"
rm -f man/en/system-login-ac.5
@@ -35,102 +33,28 @@ prepare() {
}
build() {
- cd "${pkgbase}-${pkgver}"
+ cd "${pkgname}-${pkgver}"
- PYTHONREV=2 ./configure --prefix=/usr \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --sbindir=/usr/bin
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --sbindir=/usr/bin \
+ --with-python-rev=3
make sysconfigdir=/etc/conf.d
-
- mkdir -p _install
- make install sysconfigdir=/etc/conf.d DESTDIR="$PWD"/_install
-
- find _install/usr/share -name '*.mo' | xargs ./utf8ify-mo
-
- rm -f _install/usr/lib/python*/site-packages/acutil.a
- rm -f _install/usr/lib/python*/site-packages/acutil.la
- rm -f _install/usr/share/"$pkgbase"/authconfig-tui.py
- ln -s authconfig.py _install/usr/share/"$pkgbase"/authconfig-tui.py
-
- sed -ri '1s/python/python2/' _install/usr/share/"$pkgbase"/*.py
}
-package_authconfig() {
- cd "${pkgbase}-${pkgver}"
+package() {
+ cd "${pkgname}-${pkgver}"
+
+ make install sysconfigdir=/etc/conf.d DESTDIR="$pkgdir"
+ rm "$pkgdir"/usr/lib/python*/site-packages/acutil.a
+ rm "$pkgdir"/usr/lib/python*/site-packages/acutil.la
- local _file
- for _file in _install/etc/conf.d/authconfig \
- _install/etc/pam.d/system-auth-ac \
- _install/etc/pam.d/system-login-ac \
- _install/usr/bin/authconfig \
- _install/usr/bin/authconfig-tui \
- _install/usr/bin/cacertdir_rehash \
- _install/usr/lib/python2.*/site-packages/acutil.so \
- _install/usr/share/"$pkgbase"/authconfig.py* \
- _install/usr/share/"$pkgbase"/authconfig-tui.py* \
- _install/usr/share/"$pkgbase"/authinfo.py* \
- _install/usr/share/"$pkgbase"/dnsclient.py* \
- _install/usr/share/"$pkgbase"/msgarea.py* \
- _install/usr/share/"$pkgbase"/shvfile.py* \
- _install/usr/share/locale/*/*/authconfig.mo \
- _install/usr/share/man/man5/* \
- _install/usr/share/man/man8/authconfig.* \
- _install/usr/share/man/man8/authconfig-tui.* \
- _install/usr/share/man/man8/cacertdir_rehash.* \
- _install/var/lib/authconfig
- do
- _file="${_file#_install/}"
- mkdir -p "$pkgdir"/"${_file%/*}"
- mv _install/"$_file" "$pkgdir"/"$_file"
- done
+ find "$pkgdir"/usr/share -name '*.mo' | xargs ./utf8ify-mo
chmod 700 "$pkgdir"/var/lib/authconfig
- install -D -m644 -t"$pkgdir"/usr/share/doc/"$pkgname" COPYING \
+ install -D -m644 -t"$pkgdir"/usr/share/doc/"$pkgname" HOWTO.AD-client \
NOTES \
- README.samba3 \
TODO
}
-
-package_authconfig-gtk() {
- pkgdesc='Graphical tool for setting up authentication from network services'
- depends=("${pkgbase}=${pkgver}-${pkgrel}"
- 'hicolor-icon-theme'
- 'pygtk>=2.14.0'
- 'python2-dbus'
- 'usermode')
- backup=(etc/pam.d/authconfig
- etc/pam.d/authconfig-gtk
- etc/pam.d/authconfig-tui
- etc/pam.d/system-config-authentication
- etc/security/console.apps/authconfig
- etc/security/console.apps/authconfig-gtk
- etc/security/console.apps/authconfig-tui
- etc/security/console.apps/system-config-authentication)
-
- cd "${pkgbase}-${pkgver}"
-
- local _file
- for _file in _install/etc/pam.d/authconfig \
- _install/etc/pam.d/authconfig-gtk \
- _install/etc/pam.d/authconfig-tui \
- _install/etc/pam.d/system-config-authentication \
- _install/etc/security/console.apps/authconfig \
- _install/etc/security/console.apps/authconfig-gtk \
- _install/etc/security/console.apps/authconfig-tui \
- _install/etc/security/console.apps/system-config-authentication \
- _install/usr/bin/authconfig-gtk \
- _install/usr/bin/system-config-authentication \
- _install/usr/share/"$pkgbase"/authconfig.glade \
- _install/usr/share/"$pkgbase"/authconfig-gtk.py* \
- _install/usr/share/applications/* \
- _install/usr/share/icons/hicolor/*/apps/system-config-authentication.* \
- _install/usr/share/man/man8/authconfig-gtk.* \
- _install/usr/share/man/man8/system-config-authentication.*
- do
- _file="${_file#_install/}"
- mkdir -p "$pkgdir"/"${_file%/*}"
- mv _install/"$_file" "$pkgdir"/"$_file"
- done
-}