summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAmir Zarrinkafsh2021-03-13 13:21:14 +1100
committerAmir Zarrinkafsh2021-03-13 13:21:14 +1100
commit8fe31d62590f8f6b55fca937794d9d7b95d8930f (patch)
tree320cac082a5e0e61ed63a37aecfd40f67fb7284b /PKGBUILD
parentfed4955efdf691e1940ea3a20bf20eaafe592394 (diff)
downloadaur-8fe31d62590f8f6b55fca937794d9d7b95d8930f.tar.gz
Fix and utilise go:embed
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e721713da8f6..2fd221319f03 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Amir Zarrinkafsh <nightah at me dot com>
pkgname=authelia
pkgver=4.27.1
-pkgrel=1
+pkgrel=2
pkgdesc="The Cloud ready multi-factor authentication portal for your Apps."
arch=('x86_64' 'aarch64' 'armv7h')
url="https://github.com/authelia/authelia"
@@ -28,11 +28,10 @@ build() {
cd "$srcdir/$pkgname-$pkgver/web"
yarn install --frozen-lockfile
INLINE_RUNTIME_CHUNK=false yarn build
- mv build ../public_html
+ rm -rf ../internal/server/public_html
+ mv build ../internal/server/public_html
cd ..
- cp -R api public_html/
- go get -u aletheia.icu/broccoli
- go generate internal/server/*
+ cp -R api internal/server/public_html/
sed -i "s/__BUILD_TAG__/v${pkgver}/" cmd/authelia/constants.go
sed -i "s/__BUILD_COMMIT__/$(git rev-parse --verify v${pkgver})/" cmd/authelia/constants.go
go build -ldflags '-w' -trimpath -o authelia cmd/authelia/*.go