summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAmir Zarrinkafsh2020-01-24 14:29:08 +1100
committerAmir Zarrinkafsh2020-01-24 14:29:08 +1100
commit93e481864484e49270d5dbc9b4910862157af6c2 (patch)
tree48f37b79f997e9105077a8aa313cd7b217d2c307 /PKGBUILD
parent928d3e0e9cf1f53069d47ae805200b98d018aa2a (diff)
downloadaur-93e481864484e49270d5dbc9b4910862157af6c2.tar.gz
Fix conflicts and remove unnecessary provides/makedepends
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9c3d46dc4010..ae25d0c78901 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,22 @@
# Maintainer: Amir Zarrinkafsh <nightah at me dot com>
pkgname=authelia
pkgver=4.2.0
-pkgrel=1
+pkgrel=2
pkgdesc="The Cloud ready multi-factor authentication portal for your Apps."
arch=('x86_64' 'aarch64' 'armv7h')
url="https://github.com/authelia/authelia"
license=('Apache-2.0')
makedepends=(
- 'curl'
'gcc'
'git'
'go'
'nodejs'
'yarn'
)
-provides=('authelia')
-conflicts=('authelia-bin')
+conflicts=(
+ 'authelia-bin'
+ 'authelia-git'
+)
backup=('etc/authelia/configuration.yml')
source=(
@@ -31,7 +32,7 @@ sha256sums=(
build() {
cd "$srcdir/$pkgname-$pkgver"
sed -i "s/__BUILD_TAG__/v${pkgver}/" cmd/authelia/constants.go
- sed -i "s/__BUILD_COMMIT__/$(curl https://api.github.com/repos/${pkgname}/${pkgname}/git/refs/tags/v${pkgver} | awk -F '["]' '/"sha"/{print $4}')/" cmd/authelia/constants.go
+ sed -i "s/__BUILD_COMMIT__/$(git rev-parse --verify v${pkgver})/" cmd/authelia/constants.go
go build -ldflags '-w' -trimpath -o authelia cmd/authelia/*.go
cd web
yarn install --frozen-lockfile