summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVinícius dos Santos Oliveira2015-06-14 02:01:14 -0300
committerVinícius dos Santos Oliveira2015-06-14 02:01:14 -0300
commit6ec7373ef56895b6ac6ad67f391125cf82859be2 (patch)
treec477e7f585bcfda6972ff267dbabfe112cb8af6f /PKGBUILD
downloadaur-6ec7373ef56895b6ac6ad67f391125cf82859be2.tar.gz
Genesis commit
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..8138b8677664
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Vinícius dos Santos Oliveira <vini.ipsmaker@gmail.com>
+
+pkgname=auto-complete-clang-async
+pkgver=0.5
+pkgrel=1
+pkgdesc="An emacs plugin to complete C and C++ code using libclang"
+arch=('i686' 'x86_64')
+url="https://github.com/Golevka/emacs-clang-complete-async"
+license=('GPL')
+install=$pkgname.install
+depends=('emacs' 'auto-complete' 'clang')
+makedepends=('git')
+source=("git+https://github.com/Golevka/emacs-clang-complete-async.git#tag=v${pkgver}")
+md5sums=('SKIP')
+
+build() {
+ cd "${srcdir}/emacs-clang-complete-async"
+ make
+}
+
+package() {
+ mkdir -p "${pkgdir}/usr/share/emacs/site-lisp/"
+ mkdir -p "${pkgdir}/usr/bin"
+
+ cp "${srcdir}/emacs-clang-complete-async/clang-complete" "${pkgdir}/usr/bin"
+ cp -rp "${srcdir}/emacs-clang-complete-async/auto-complete-clang-async.el" \
+ "${pkgdir}/usr/share/emacs/site-lisp"
+}
+
+# vim:set ts=2 sw=2 et: