summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjimothy2022-01-31 14:47:43 -0500
committerjimothy2022-01-31 14:47:43 -0500
commit16a641c7c7eb6c86554ebb06c45504f355d554d4 (patch)
tree374ee699f85717eec361ae13de57500b4d64911f /PKGBUILD
parent335dbc62f2f95eabb48b9e4522ca8ce1adcf8205 (diff)
downloadaur-16a641c7c7eb6c86554ebb06c45504f355d554d4.tar.gz
updated license/added pkgver
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 03b153d2a8b3..68404690d454 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# Maintainer: Timothy Newton <timothynewton1998@gmail.com>
pkgname=auto-rotation-hdaps-git
-pkgver=1.1
+pkgver=r8.746c19e
pkgrel=1
pkgdesc="This application adds auto-rotation functionality to tablet/laptop devices with Linux that have HDAPS accelerometers such as the X201 tablet Thinkpad."
arch=("any")
url="https://github.com/Unicornasaurous/auto_rotation_hdaps.git"
-license=()
+license=("MIT")
groups=()
depends=("libinput" "hdapsd" "python")
makedepends=("git")
@@ -21,6 +21,11 @@ source=("$pkgname::git+$url")
noextract=()
sha256sums=("SKIP")
+pkgver()
+{
+ cd $pkgname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
package() {
cd $pkgname