summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjimothy2022-01-30 20:44:38 -0500
committerjimothy2022-01-30 20:44:38 -0500
commit335dbc62f2f95eabb48b9e4522ca8ce1adcf8205 (patch)
treeeb55f2eaa2a3a263fe8802be96d10a602d575c3d /PKGBUILD
downloadaur-335dbc62f2f95eabb48b9e4522ca8ce1adcf8205.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..03b153d2a8b3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Timothy Newton <timothynewton1998@gmail.com>
+pkgname=auto-rotation-hdaps-git
+pkgver=1.1
+pkgrel=1
+pkgdesc="This application adds auto-rotation functionality to tablet/laptop devices with Linux that have HDAPS accelerometers such as the X201 tablet Thinkpad."
+arch=("any")
+url="https://github.com/Unicornasaurous/auto_rotation_hdaps.git"
+license=()
+groups=()
+depends=("libinput" "hdapsd" "python")
+makedepends=("git")
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install="$pkgname.install"
+changelog=
+source=("$pkgname::git+$url")
+noextract=()
+sha256sums=("SKIP")
+
+
+package() {
+ cd $pkgname
+
+ install -d $pkgdir/usr/bin
+
+ cp auto_rotate.py $pkgdir/usr/bin
+ cp tablet_mode_detection.py $pkgdir/usr/bin
+}