summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorloh.tar2024-03-03 10:49:29 +0100
committerloh.tar2024-03-03 10:49:29 +0100
commit68381522e913e9cf169c522fa0c73f66c5c52135 (patch)
treec15a6ed87f785933d3b18953b8fc66fdfccc0c46 /PKGBUILD
downloadaur-68381522e913e9cf169c522fa0c73f66c5c52135.tar.gz
Hello Arch-World!
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6d72c45dbdb2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: loh.tar <loh.tar at googlemail dot com>
+pkgname='auto-suspend'
+pkgver='0.8.1'
+pkgrel='1'
+pkgdesc='A simple but handy system monitor in pure bash'
+arch=('any')
+url="https://github.com/loh-tar/$pkgname"
+license=('GPL-3.0-or-later')
+# namcap warn nothing of these are needed, only bash is fine
+depends=('bash' 'iputils' 'grep' 'procps-ng' 'findutils')
+# optdepends=() # No systemd or samba, there is no benefit to install explicit
+backup=("etc/$pkgname.conf")
+install="$pkgname.install"
+source=("$pkgname-$pkgver.tar.gz::https://github.com/loh-tar/$pkgname/archive/v$pkgver.tar.gz")
+sha256sums=('81d52fc9822c508a6442d7cafe483bea8e4e4140bb491e51aa09023ba9a89f42')
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ install -Dm755 "auto-suspend" "${pkgdir}/usr/bin/auto-suspend"
+ install -Dm644 "auto-suspend.conf" "${pkgdir}/etc/auto-suspend.conf"
+ install -Dm644 "auto-suspend-daemon.service" "${pkgdir}/usr/lib/systemd/system/auto-suspend-daemon.service"
+ install -Dm644 "auto-suspend-clerk.service" "${pkgdir}/usr/lib/systemd/system/auto-suspend-clerk.service"
+ install -Dm644 "auto-suspend-clerk.timer" "${pkgdir}/usr/lib/systemd/system/auto-suspend-clerk.timer"
+ install -Dm644 "README" "${pkgdir}/usr/share/doc/${pkgname}/README"
+}