summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormichaelb2020-07-16 14:43:31 +0200
committermichaelb2020-07-16 14:43:31 +0200
commita06c0f7ca47cc2f556e2d080e5fe3e49f79d9b8e (patch)
treef58d0e9f05f3d837339ba58670d0ba96e7ede848 /PKGBUILD
downloadaur-a06c0f7ca47cc2f556e2d080e5fe3e49f79d9b8e.tar.gz
PKGBUILD + .SRCINFO 1st push
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8b7888704760
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Michael Bleuez <michael.bleuez2 at gmail dot com>
+
+pkgname='auto-ytdl-git'
+pkgdesc='aytdl, a youtube-dl wrapper with automatisation features for music.'
+pkgver=1.0.0
+pkgrel=1
+arch=('any')
+url='https://github.com/michael/auto-ytdl'
+license=('GPL3')
+depends=('ffmpeg' 'youtube-dl')
+makedepends=('python-setuptools' 'git')
+
+md5sums=('SKIP')
+source=('auto-ytdl::git+http://github.com/michaelb/auto-ytdl.git')
+
+package() {
+ cd "${srcdir}/auto-ytdl"
+ python -m setuptools.launch setup.py install --root="$pkgdir/" --optimize=1
+}