summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMattias Andrée2015-12-21 12:40:58 +0100
committerMattias Andrée2015-12-21 12:40:58 +0100
commit612cfeebd5c40a30326dc738bd415605842a9abc (patch)
tree0afed489c764a87ea80578e574c28523746b6bab /PKGBUILD
downloadaur-612cfeebd5c40a30326dc738bd415605842a9abc.tar.gz
Initial import, version 0.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..551f5d8b5135
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
+
+pkgname=autohaltd
+pkgver=0.1
+pkgrel=1
+pkgdesc="Bring the system down when it is inactive"
+arch=(i686 x86_64)
+url="https://github.com/maandree/autohaltd"
+license=('GPL3' 'custom:GFDL1.3')
+depends=(sysvinit glibc)
+makedepends=(glibc make coreutils gcc 'texinfo>=4.11')
+install=$pkgname.install
+source=($url/archive/$pkgver.tar.gz)
+sha256sums=(2e65913cc190b178ecf621c1a26a1c289180ffa6fd755b70a39d1fc08d09b5f0)
+
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ env -u DEBUG ./configure --prefix=/usr --sbindir=/usr/bin --libexecdir=/usr/lib
+ make
+}
+
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make install DESTDIR="$pkgdir"
+}
+