summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDmitry Kharitonov2019-02-12 17:20:48 +0500
committerDmitry Kharitonov2019-02-12 17:20:48 +0500
commit296c71cd2930c72bf7de6331f4bd45762e5792c2 (patch)
tree2498e8230b8404cc179cb76f9ed78323f80d8820 /PKGBUILD
downloadaur-296c71cd2930c72bf7de6331f4bd45762e5792c2.tar.gz
Initial import; updated the architectures
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ab2b5b6cc7ca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Dmitry Kharitonov <darksab0r@gmail.com>
+# Contributor: Dave Blair <mail@dave-blair.de>
+
+pkgname=autokey
+pkgver=0.95.6
+pkgrel=1
+pkgdesc="AutoKey, a desktop automation utility for Linux and X11, updated to run on Python 3"
+arch=('i686' 'x86_64')
+url="https://github.com/autokey/autokey"
+depends=('python' 'wmctrl' 'hicolor-icon-theme' 'python-dbus' 'python-pyinotify'
+ 'zenity' 'xautomation' 'imagemagick' 'xorg-xwd' 'python-xlib' 'python-six'
+ 'python-gobject' 'gtksourceview3' 'libnotify' 'libappindicator-gtk3'
+ 'gtk-update-icon-cache')
+makedepends=('python-setuptools')
+optdepends=('kdialog: for Qt interface'
+ 'python-pyqt5: for Qt interface'
+ 'python-qscintilla-qt5: for Qt interface'
+ 'qt-at-spi: to work with KDE/Qt applications'
+ 'python-atspi: for ATSPI in Gtk interface')
+replaces=('autokey-py3')
+license=('GPL3')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/autokey-py3/autokey/archive/v${pkgver}.tar.gz")
+sha256sums=('d02aa25107c652d6eb960be0e7722bcc07d997a41fbf06b29babc0389ce3ee0d')
+
+package() {
+ cd "$srcdir/autokey-${pkgver}"
+ python setup.py install --root="$pkgdir" --optimize=1
+}