summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDmitry Kharitonov2019-11-09 04:36:02 +0500
committerDmitry Kharitonov2019-11-09 04:36:02 +0500
commita1a3ea58e511b02da33e310139f08db348bbb7f9 (patch)
tree5265c814f602f259e67849c7d9362225315e5260 /PKGBUILD
parent49e088c4f768d6578ae655a99abd38f058d83d5f (diff)
downloadaur-a1a3ea58e511b02da33e310139f08db348bbb7f9.tar.gz
0.95.8
Added qt5-svg optdep for autokey-qt; removed deps that were already satisfied
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 80ac66f40d01..b3410c60bd23 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,24 +2,25 @@
# Contributor: Dave Blair <mail@dave-blair.de>
pkgname=autokey
-pkgver=0.95.7
-pkgrel=2
+pkgver=0.95.8
+pkgrel=1
pkgdesc="AutoKey, a desktop automation utility for Linux and X11, updated to run on Python 3"
arch=('i686' 'x86_64')
url="https://github.com/autokey/autokey"
-depends=('python' 'wmctrl' 'hicolor-icon-theme' 'python-dbus' 'python-pyinotify'
+depends=('python' 'wmctrl' 'python-dbus' 'python-pyinotify'
'zenity' 'xautomation' 'imagemagick' 'xorg-xwd' 'python-xlib' 'python-setuptools'
- 'python-six' 'python-gobject' 'gtksourceview3' 'libnotify'
+ 'python-gobject' 'gtksourceview3' 'libnotify'
'libappindicator-gtk3' 'gtk-update-icon-cache')
optdepends=('kdialog: for Qt interface'
'python-pyqt5: for Qt interface'
'python-qscintilla-qt5: for Qt interface'
+ 'qt5-svg: for Qt interface'
'qt-at-spi: to work with KDE/Qt applications'
'python-atspi: for ATSPI in Gtk interface')
replaces=('autokey-py3')
license=('GPL3')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/autokey-py3/autokey/archive/v${pkgver}.tar.gz")
-sha256sums=('b126fe4db8327e9575bd689d57c5e09236f3c08e9ac571b7cc257baf6c3a9d68')
+sha256sums=('5de4b11c999af7f41273cf07e13c35f4c58c467e6c6df25e417c8b135c06bb49')
package() {
cd "$srcdir/autokey-${pkgver}"