summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorflorianmw2019-03-16 17:19:27 +0100
committerflorianmw2019-03-16 17:19:27 +0100
commite74a584a5f659051094e88887a0ccaa3789f86cd (patch)
treec63f13d3c7d22c5d34bf6fe4de3a9dc8af9f5b76 /PKGBUILD
parent226ce5b58d6cabf98800e1739668941eb9b10f55 (diff)
downloadaur-e74a584a5f659051094e88887a0ccaa3789f86cd.tar.gz
add missing timer and autostart
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 12 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 28693473f238..51009f3592e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,23 @@
pkgname=('automathemely')
_name='AutomaThemely'
pkgver='1.3'
-pkgrel=1
+pkgrel=2
pkgdesc="Simple, set-and-forget python application for changing between GNOME themes according to light and dark hours."
url="https://github.com/C2N14/AutomaThemely"
depends=('python')
makedepends=('python-setuptools')
license=('GPL-3.0')
arch=('any')
-source=("https://github.com/C2N14/${_name}/archive/v${pkgver}.tar.gz")
-sha256sums=('14e5100eb911ab8e5667a3358e1e7ed6540fd1a294ba4d451d4db480b08c3555')
+install=${pkgname}.install
+source=("https://github.com/C2N14/${_name}/archive/v${pkgver}.tar.gz"
+ ${pkgname}.install
+ ${pkgname}.service
+ ${pkgname}.timer
+)
+sha256sums=('14e5100eb911ab8e5667a3358e1e7ed6540fd1a294ba4d451d4db480b08c3555'
+ 'd89733856d5d93f93ca29ea769c6ae3e2841378c89b88fe1acd239fa7dd5026f'
+ '6c0e4e6076f2cce0cef8c5aec79f9ea6106240051b1d556eabea4c391fe0d834'
+ '0b39fc8abf200b1438b01deb48133817e4dc1cd6e7e41cebe7e82118ed96999e')
build() {
cd "${srcdir}/${_name}-${pkgver}"
@@ -22,4 +30,5 @@ package() {
depends+=('python-astral' 'python-tzlocal' 'python-schedule')
cd "${srcdir}/${_name}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 -t ${pkgdir}/usr/lib/systemd/user ${srcdir}/${pkgname}.service ${srcdir}/${pkgname}.timer
}