summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJohannes Wienke2015-09-21 16:10:58 +0200
committerJohannes Wienke2015-09-21 16:10:58 +0200
commit268929574150e09cfa1743a7d2d8f1ee1682245d (patch)
treec062cfc1d7f2b3758611d221ce8c6fce4e17dd0b /PKGBUILD
downloadaur-268929574150e09cfa1743a7d2d8f1ee1682245d.tar.gz
Initial release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cd3991ef2516
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Johannes Wienke <languitar@semipol.de>
+
+pkgname=autosuspend
+pkgver=0.1.1
+pkgrel=1
+pkgdesc="A daemon to suspend your server in case of inactivity"
+arch=(any)
+url="https://github.com/languitar/autosuspend"
+license=('GPL2')
+depends=('python' 'python-psutil')
+optdepends=('python-mpd2: MPD playing status checks')
+makedepends=('python-setuptools')
+source=("https://github.com/languitar/autosuspend/archive/release-${pkgver}.tar.gz")
+md5sums=('12bf8d9b54daf951ee2c866cab955479')
+
+package() {
+ cd "$pkgname-release-${pkgver}"
+ python3 setup.py install --root="$pkgdir/" --install-data=/usr
+ # setuptools install_data is a nightmare, and cannot be made to respect the
+ # filesystem hierarchy. Do things manually instead.
+ mv "$pkgdir/usr/etc" "$pkgdir"
+}