summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJohannes Wienke2020-01-19 20:35:09 +0100
committerJohannes Wienke2020-01-19 20:35:09 +0100
commit3fd85ea191255a3c955a74cc8c20ef3562dc8a2c (patch)
tree4160f900de3387f9ac46956b2fb04e6aa7cde3d2 /PKGBUILD
parent470488c9481b52194588019c8386b592f35d8148 (diff)
downloadaur-3fd85ea191255a3c955a74cc8c20ef3562dc8a2c.tar.gz
Version bump to 3.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 13 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 89c9b9d0da90..b87dd901e269 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Johannes Wienke <languitar@semipol.de>
pkgname=autosuspend
-pkgver=2.0.6
-pkgrel=2
+pkgver=3.0
+pkgrel=1
pkgdesc="A daemon to suspend and wake up a system based on configurable checks"
arch=(any)
url="https://github.com/languitar/autosuspend"
license=('GPL2')
-depends=('python' 'python-psutil')
+depends=('python' 'python-psutil' 'python-portalocker')
optdepends=('python-dbus: logind session discovery'
'python-mpd2: MPD playing status check'
'python-requests: network-based checks'
@@ -19,14 +19,22 @@ optdepends=('python-dbus: logind session discovery'
'python-requests-file: file:// URL support'
'iputils: ping check'
'xprintidle: X server idle time check')
-makedepends=('python-setuptools' 'python-pytest-runner' 'python-sphinx' 'python-sphinx_rtd_theme' 'python-sphinx-issues')
+makedepends=('python-setuptools'
+ 'python-pytest-runner'
+ 'python-sphinx'
+ 'python-sphinx_rtd_theme'
+ 'python-sphinx-issues'
+ 'python-sphinxcontrib-plantuml'
+ 'python-sphinx-autodoc-typehints')
source=("https://github.com/languitar/autosuspend/archive/v${pkgver}.tar.gz")
-sha256sums=('a2593ebb29a7c0b28244920504ca9d4550fbf398d6abf476bcf0f66c6520e9ba')
+sha256sums=('9218302df40c0517361fcb9983e3435d6c1f6e16a7e2c00b65f533605abd5f4d')
+install="${pkgname}.install"
backup=('etc/autosuspend.conf'
'etc/autosuspend-logging.conf')
build() {
cd "$pkgname-${pkgver}"
+ export PYTHONPATH=$(pwd)/src
python3 setup.py build_sphinx -a -b html
python3 setup.py build_sphinx -a -b man
}