summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJason Nader2020-02-19 18:50:23 +0900
committerJason Nader2020-02-19 18:50:23 +0900
commitfa78e0affe9322f89ed07fb8b092874b00e3f655 (patch)
treecdbc9e8052f98f679e96091c365b1af61100a061 /PKGBUILD
downloadaur-fa78e0affe9322f89ed07fb8b092874b00e3f655.tar.gz
First commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..64678ec27b4f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Jason Nader <jason.nader@protonmail.com>
+pkgname=('autotiling-git')
+_pkgname=autotiling
+pkgver=r24.6854508
+pkgrel=1
+pkgdesc="Script for sway and i3 to automatically switch the horizontal / vertical window split orientation"
+arch=('x86_64')
+url="https://github.com/nwg-piotr/autotiling"
+license=('GPL3')
+depends=('python-i3ipc')
+makedepends=('git')
+source=("${pkgname%-*}::git+https://github.com/nwg-piotr/autotiling.git")
+md5sums=('SKIP')
+provides=("autotiling")
+conflicts=("autotiling")
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$_pkgname"
+ install -D -t "$pkgdir/usr/lib/$_pkgname" autotiling.py
+ install -D -t "$pkgdir/usr/bin" autotiling
+}
+