summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-07-06 05:14:47 +0300
committerDimitris Kiziridis2020-07-06 05:14:47 +0300
commit3ba078697e299990cb4ea1c4a0320e18ae45ddea (patch)
tree3197e5b23abaacb98808b70b8c012c85124f75d7 /PKGBUILD
parent4b05c90f103bcc9d16bb98425262bbab75e4194e (diff)
downloadaur-3ba078697e299990cb4ea1c4a0320e18ae45ddea.tar.gz
Update 1.15.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD62
1 files changed, 27 insertions, 35 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c1ffb3855108..37d274177268 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,47 +1,39 @@
-# This is an example PKGBUILD file. Use this as a start to creating your own,
-# and remove these comments. For more information, see 'man PKGBUILD'.
-# NOTE: Please fill out the license field for your package! If it is unknown,
-# then please put 'unknown'.
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+# Contributor: Mario Steele <mario@ruby-im.net>
-# Maintainer: Mario Steele <mario@ruby-im.net>
pkgname=autovala
-pkgver=1.1.0
+pkgver=1.15.1
pkgrel=1
-pkgdesc=""
-arch=('any')
-url=""
+pkgdesc="A program that automatically generates CMake and Meson configuration files for your Vala project"
+arch=('x86_64')
+url="https://gitlab.com/rastersoft/autovala"
license=('GPL3')
groups=('vala')
-depends=(
- 'vala>=0.20.0'
- 'cmake>=3.5.0'
- 'libgee>=0.16.0'
- 'gtk3>=3.18.0'
- 'bash-completion>=2.3'
-)
-makedepends=(
- 'vala>=0.20.0'
- 'cmake>=3.5.0'
- 'libgee>=0.16.0'
- 'gtk3>=3.18.0'
- 'pandoc>=1.17.0.0'
- 'bash-completion>=2.3'
-)
-provides=('autovala')
+depends=('make'
+ 'vte3'
+ 'libgee'
+ 'bash-completion')
+makedepends=('vala'
+ 'cmake'
+ 'libgee'
+ 'gtk3'
+ 'pandoc'
+ 'bash-completion'
+ 'gobject-introspection')
install=autovala.install
-source=("http://github.com/rastersoft/$pkgname/archive/$pkgver.tar.gz")
-md5sums=('2989d6e3039dd6fa1cd676eeca914f27')
+source=("${pkgname}-${pkgver}.tar.gz::https://gitlab.com/rastersoft/autovala/-/archive/${pkgver}/autovala-${pkgver}.tar.gz")
+sha256sums=('af77e46d7ac50eb34e63ab5477a1f94f696f05fae41b21282961819820051f4b')
build() {
- cd "$pkgname-$pkgver"
- rm -rf install
- mkdir install
- cd install
- cmake .. -DCMAKE_INSTALL_PREFIX="/usr" -DCMAKE_INSTALL_LIBDIR="/usr/lib"
+ cd "${pkgname}-${pkgver}"
+ rm -rf build
+ mkdir build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX="/usr" -DCMAKE_INSTALL_LIBDIR="/usr/lib" ..
make
}
package() {
- cd "$pkgname-$pkgver"/install
- make DESTDIR="$pkgdir/" install
-}
+ cd "${pkgname}-${pkgver}/build"
+ make DESTDIR="${pkgdir}" install
+} \ No newline at end of file