summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMario Steele2016-05-27 21:44:39 -0400
committerMario Steele2016-05-27 21:44:39 -0400
commit97b32199fda53b4db8ea7171c9ac5350631399cb (patch)
tree3658d5b89b13b786c61090c3c11ccf038c9556d7 /PKGBUILD
downloadaur-97b32199fda53b4db8ea7171c9ac5350631399cb.tar.gz
Initial creation of the Package for AutoVala
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ed96ca590519
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Mario Steele <mario@ruby-im.net>
+pkgname=autovala
+pkgver=0.99.38
+pkgrel=1
+pkgdesc=""
+arch=('any')
+url=""
+license=('GPL3')
+groups=('vala')
+depends=(
+ 'vala>=0.20.0'
+ 'cmake>=3.5.0'
+ 'libgee>=0.16.0'
+ 'gtk3>=3.18.0'
+ 'bash-completion>=2.3'
+)
+makedepends=(
+ 'vala>=0.20.0'
+ 'cmake>=3.5.0'
+ 'libgee>=0.16.0'
+ 'gtk3>=3.18.0'
+ 'pandoc>=1.17.0.0'
+ 'bash-completion>=2.3'
+)
+provides=('autovala')
+install=autovala.install
+source=("http://github.com/rastersoft/$pkgname/archive/$pkgver.tar.gz")
+md5sums=('03e366e34d8455a43942c20ff410f127')
+
+build() {
+ cd "$pkgname-$pkgver"
+ rm -rf install
+ mkdir install
+ cd install
+ cmake .. -DCMAKE_INSTALL_PREFIX="/usr" -DCMAKE_INSTALL_LIBDIR="/usr/lib"
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"/install
+ make DESTDIR="$pkgdir/" install
+}