summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGrey Christoforo2015-10-12 13:41:53 +0100
committerGrey Christoforo2015-10-12 13:41:53 +0100
commit42804c4057c85cfe4afe022ff9eb246eee6b70bc (patch)
tree94d5d3d93c009636d8a983b43383635085993b01 /PKGBUILD
downloadaur-42804c4057c85cfe4afe022ff9eb246eee6b70bc.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD81
1 files changed, 81 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..362fa7628597
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,81 @@
+# $Id$
+# Maintainer: Grey Christoforo <first name [at] last name [dot] net>
+
+pkgname=avahi-git
+pkgver=0.6.32.rc.r0.g4a087c4
+pkgrel=1
+pkgdesc='Multicast DNS-SD / Zeroconf Suite git master'
+url='http://www.avahi.org/'
+license=(LGPL)
+arch=(i686 x86_64)
+depends=(expat libdaemon glib2 libcap gdbm dbus)
+makedepends=(git qt4 pygtk mono intltool python2-dbus gtk-sharp-2 gobject-introspection gtk3
+ xmltoman python-dbus)
+optdepends=('gtk3: avahi-discover-standalone, bshell, bssh, bvnc'
+ 'gtk2: gtk2 bindings'
+ 'qt4: qt4 bindings'
+ 'pygtk: avahi-bookmarks, avahi-discover'
+ 'python2-twisted: avahi-bookmarks'
+ 'mono: mono bindings'
+ 'python2-dbus: avahi-discover'
+ 'nss-mdns: NSS support for mDNS')
+conflicts=(howl mdnsresponder)
+provides=(howl mdnsresponder)
+install=avahi.install
+options=(!emptydirs)
+backup=(etc/avahi/{hosts,avahi-daemon.conf,services/{ssh,sftp-ssh}.service}
+ usr/lib/avahi/service-types.db usr/share/avahi/service-types)
+source=("git://github.com/lathiat/avahi")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd avahi
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd avahi
+ NOCONFIGURE=1 ./autogen.sh
+}
+
+build() {
+ cd avahi
+ export MOC_QT4=/usr/bin/moc-qt4 PYTHON=/usr/bin/python2
+
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --sbindir=/usr/bin \
+ --disable-monodoc \
+ --disable-qt3 \
+ --enable-compat-libdns_sd \
+ --enable-compat-howl \
+ --with-distro=archlinux \
+ --with-avahi-priv-access-group=network \
+ --with-autoipd-user=avahi \
+ --with-autoipd-group=avahi \
+ --with-systemdsystemunitdir=/usr/lib/systemd/system
+
+ cp -a avahi-python/avahi avahi-python/avahi3
+
+ make
+ make -C avahi-python/avahi3 PYTHON=/usr/bin/python3
+}
+
+package() {
+ cd avahi
+ make DESTDIR="$pkgdir" install
+ make DESTDIR="$pkgdir" -C avahi-python/avahi3 install \
+ PYTHON=/usr/bin/python3 pythondir=/usr/lib/python3.5/site-packages
+
+ # howl compat
+ ln -s avahi-compat-howl "$pkgdir/usr/include/howl"
+ ln -s avahi-compat-howl.pc "$pkgdir/usr/lib/pkgconfig/howl.pc"
+
+ # mdnsresponder compat
+ ln -s avahi-compat-libdns_sd/dns_sd.h "$pkgdir/usr/include/dns_sd.h"
+
+ # see FS#42638
+ ln -s avahi-daemon.service "$pkgdir/usr/lib/systemd/system/dbus-org.freedesktop.Avahi.service"
+}