summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSanskritFritz2015-06-14 00:42:18 +0200
committerSanskritFritz2015-06-14 00:42:18 +0200
commit96668c4057bcec8b35fcce697f760a47ce701a7e (patch)
treeabbe2b5ebfe19f6885e170a98be0763077434b84 /PKGBUILD
downloadaur-96668c4057bcec8b35fcce697f760a47ce701a7e.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD51
1 files changed, 51 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f3e7bb1f87d7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: SanskritFritz (gmail)
+# Contributor: Balló György <ballogyor+arch at gmail dot com>
+# Contributor: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
+# Contributor: Timm Preetz <timm@preetz.us>
+# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
+# Contributor: serendipoldius (AUR)
+
+pkgname=avant-window-navigator
+pkgver=0.4.2
+pkgrel=4
+pkgdesc='AWN is a customisable dock-like bar at the edge of the screen.'
+arch=('x86_64' 'i686')
+url='https://launchpad.net/awn'
+license=('GPL')
+depends=('libdesktop-agnostic' 'libwnck' 'libgtop' 'gconf' 'python2-dbus' 'pygtk' 'python2-xdg' 'hicolor-icon-theme' 'xdg-utils' 'gtkmm')
+makedepends=('gtk-doc' 'vala' 'intltool')
+options=('!libtool')
+install=$pkgname.install
+source=("http://launchpad.net/awn/0.4/$pkgver/+download/$pkgname-$pkgver.tar.gz")
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ # Python2 fix
+ sed -i 's@^#!.*python$@#!/usr/bin/python2@' awn-settings/{awnSettings.py.in,awnSettingsHelper.py}
+ sed -i 's/with("python"/with("python2"/' applet-activation/main.cc
+
+ autoreconf -fi
+ ./configure --prefix=/usr --sysconfdir=/etc \
+ --disable-static \
+ PYTHON=/usr/bin/python2
+ make
+}
+
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make check
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1 DESTDIR="$pkgdir" install
+
+ install -m755 -d "$pkgdir/usr/share/gconf/schemas"
+ gconf-merge-schema "$pkgdir/usr/share/gconf/schemas/awn.schemas" "$pkgdir"/etc/gconf/schemas/*.schemas
+ rm -r "$pkgdir/etc"
+}
+
+md5sums=('df3bd413de19bdda461df7ed4f9e2409')