summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2019-06-09 18:54:10 +0000
committerDaniel Bermond2019-06-09 19:09:55 +0000
commitb7700e39b25ebd168bbeb34dac20530f85c02c38 (patch)
treea9c8af093540144ae6dd3b968e08b2782af2fdf8 /PKGBUILD
parentd12170ed5aba44484d572bbf75b0247fe76469a0 (diff)
downloadaur-b7700e39b25ebd168bbeb34dac20530f85c02c38.tar.gz
Major rewrite with many fixes and improvements
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD79
1 files changed, 42 insertions, 37 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 205ef3054eee..79a046ed2aa4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,51 +1,56 @@
-# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
+# Maintainer : Daniel Bermond < gmail-com: danielbermond >
+# Contributor: Christopher Arndt <aur -at- chrisarndt -dot- de>
pkgname=avbin
pkgver=10
-pkgrel=2
-_gittag="$pkgname-$pkgver"
-_gitsubmodule="https://github.com/AVbin/libav.git"
-pkgdesc="Cross-platform media decoding library"
-arch=('i686' 'x86_64')
-url="http://avbin.github.com/"
-license=('LGPL')
+pkgrel=3
+pkgdesc='A C library that provides a wrapper around Libav’s video and audio decoding functionality'
+arch=('x86_64')
+url='https://avbin.github.io/'
+license=('LGPL3')
depends=('bzip2' 'zlib')
-conflicts=('avbin7')
makedepends=('git' 'yasm')
-options=('!makeflags')
-# The build script relies on being run in a git checkout,
-# the downloadable release tarball doesn't work with it
-source=("${pkgname}::git+https://github.com/AVbin/AVbin.git")
-sha256sums=('SKIP')
+source=("git+https://github.com/AVbin/AVbin.git#tag=avbin-${pkgver}"
+ 'libav-avbin'::'git+https://github.com/AVbin/libav.git'
+ '0001-avbin-remove-unwanted-optimization.patch'
+ '0002-avbin-fix-link-and-add-full-relro.patch'
+ '0003-avbin-faster-build.patch'
+ 'avbin.pc')
+sha256sums=('SKIP'
+ 'SKIP'
+ '8f8b20d6e57bdc6bf73723691740ae35b157785ebda5764a7611a68df427c30a'
+ 'fa8f7263326b10f968836f5fe7ae9efef04cdce58a28cfd3f7cb93985fffb469'
+ 'be5e45a35c35229c68adfc1606c31d479a4813926de1c022d3919c7592d92c8b'
+ 'd43b24480805ede648a5851465b3071fde75d4114f8a6c84430902075767667f')
prepare() {
- cd "${srcdir}/${pkgname}"
-
- if [ ! -e libav/Makefile ]; then
- git rm libav
- git submodule add --force ${_gitsubmodule} libav
- fi
-
- git checkout "${_gittag}"
- cd libav
- git checkout v9.5
+ cd AVbin
+
+ git submodule init
+ git config --local "submodule.libav.url" "${srcdir}/libav-avbin"
+ git submodule update
+
+ patch -Np1 -i "${srcdir}/0001-avbin-remove-unwanted-optimization.patch"
+ patch -Np1 -i "${srcdir}/0002-avbin-fix-link-and-add-full-relro.patch"
+ patch -Np1 -i "${srcdir}/0003-avbin-faster-build.patch"
}
build() {
- cd "${srcdir}/${pkgname}"
-
- target="linux-$(echo $CARCH | sed -e 's/_/-/')"
- msg "Building target ${target}..."
- # Linux Makefile uses LDFLAGS directly for ld command line
- export LDFLAGS="$(echo $LDFLAGS | sed -e 's/^-Wl,//')"
- bash -x build.sh --fast ${target}
+ cd AVbin
+
+ unset LDFLAGS # won't build if setted, modified by patch
+
+ ./build.sh --fast linux-x86-64
}
package() {
- cd "${srcdir}/${pkgname}"
-
- target="linux-$(echo $CARCH | sed -e 's/_/-/')"
- install -dm755 "$pkgdir/usr/lib"
- install -m644 "dist/${target}/libavbin.so.${pkgver}" "$pkgdir/usr/lib"
- ln -sf "libavbin.so.${pkgver}" "$pkgdir/usr/lib/libavbin.so"
+ # header
+ install -D -m644 AVbin/include/avbin.h -t "${pkgdir}/usr/include"
+
+ # library
+ install -D -m755 "AVbin/dist/linux-x86-64/libavbin.so.${pkgver}" -t "${pkgdir}/usr/lib"
+ ln -s "libavbin.so.${pkgver}" "${pkgdir}/usr/lib/libavbin.so"
+
+ # pkgconfig
+ install -D -m644 avbin.pc -t "${pkgdir}/usr/lib/pkgconfig"
}