summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
author7452756332017-05-30 14:52:33 +0800
committer7452756332017-05-30 14:52:33 +0800
commitae806979896b23217d751debac3ce7bc1ff11848 (patch)
treeec99832d5abc08acfc9ab06681695b2f9fe7fe90 /PKGBUILD
parent39030d6fd73117c00e3264f8c23e53cba2a0dd5a (diff)
downloadaur-ae806979896b23217d751debac3ce7bc1ff11848.tar.gz
change format
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 89f98d577e9f..0b60f96aa724 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,27 @@
# Maintainer: DATSD <dastudiodirector at gmail dot com>
_basename=avhttp
pkgname=${_basename}-git
-pkgver=r887.f9d6e36
+pkgver=2.9.9.r99
pkgrel=1
pkgdesc='Concurrent http downloader'
arch=('any')
url='http://avplayer.org/avhttp.html'
license=('custom')
-depends=('boost-libs')
+depends=('boost')
optdepends=(
'zlib: gzip support'
'openssl: https support'
)
-makedepends=('cmake' 'git' 'boost')
-provides=('avhttp')
-conflicts=('avhttp')
-source=("git+https://github.com/avplayer/avhttp.git")
+makedepends=('cmake' 'git')
+provides=("${_basename}=${pkgver}")
+conflicts=("${_basename}")
+source=("${_basename}::git+https://github.com/avplayer/avhttp.git")
sha256sums=('SKIP')
pkgver()
{
cd "${srcdir}/${_basename}"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long --tags | sed 's/\([^-]*\)-g.*/r\1/;s/-/./g' | cut -c2-
}
build()
@@ -39,7 +39,7 @@ build()
package()
{
- cd "${_basename}/build"
+ cd "${srcdir}/${_basename}/build"
make install DESTDIR="${pkgdir}/"
# Install the documentation