summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsL1pKn072023-09-10 12:09:54 +0200
committersL1pKn072023-09-10 12:11:28 +0200
commita66e9e6f154dac40d5d19aad9698564c9ea2db60 (patch)
tree973156dce03a11e82e671e3a4fcdaca1e2307023 /PKGBUILD
parentd448ee1fde9b0dcb07d783f13c381c2bb7fe0362 (diff)
downloadaur-a66e9e6f154dac40d5d19aad9698564c9ea2db60.tar.gz
bump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD278
1 files changed, 164 insertions, 114 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 736a65b71c73..01554a807f01 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,68 +1,79 @@
# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
pkgbase=avidemux-git
-pkgname=('avidemux-core-git'
- 'avidemux-qt5-git'
- 'avidemux-qt6-git'
- 'avidemux-cli-git'
- )
-pkgver=2.8.1.220217.d42b59c5b
+pkgname=(
+ 'avidemux-core-git'
+ 'avidemux-qt5-git'
+ 'avidemux-qt6-git'
+ 'avidemux-cli-git'
+)
+pkgver=2.8.2.230910.dd023f161
pkgrel=1
pkgdesc="A graphical/cli tool to edit video (filter/re-encode/split). (GIT version)"
arch=('x86_64')
url='http://www.avidemux.org'
license=('GPL2')
-makedepends=('git'
- 'cmake'
- 'yasm'
- 'nasm'
- 'aom'
- 'a52dec'
- 'aften'
- 'dcaenc'
- 'faac'
- 'faad2'
- 'fribidi'
- 'jack'
- 'lame'
- 'libass'
- 'libfdk-aac'
- 'libmad'
- 'libmp4v2'
- 'libdca'
- 'libpulse'
- 'libva'
- 'libvdpau'
- 'libvpx'
- 'libvorbis'
- 'opencore-amr'
- 'twolame'
- 'xvidcore'
- 'x264'
- 'x265'
- 'sqlite'
- 'glu'
- 'qt5-script'
- 'qt5-tools'
- 'qt6-base'
- 'qt6-tools'
- 'libxv'
- 'vapoursynth'
- 'hicolor-icon-theme'
- 'setconf'
- )
-source=('avidemux::git+https://github.com/mean00/avidemux2.git'
- 'git+https://github.com/mean00/avidemux2_i18n.git'
- 'fix_verbose.patch'
- 'add_settings_pluginui_message_error.patch'
- 'opus_check.patch'
- )
-sha256sums=('SKIP'
- 'SKIP'
- '4f751cbb3a65f904f7c0ad68473880e2a9edcda332a293e20ad238280ec52884'
- 'c5b5d3d7bcdf4c588a780c12fdac7791ddb0527db438c85b4c1c078507da2f0b'
- 'ae6d2c93163b7b760591688c7811dfdd4a952ed9074d8cbdf4953b701f0fa7db'
- )
+makedepends=(
+ 'git'
+ 'cmake'
+ 'yasm'
+ 'nasm'
+ 'aom'
+ 'a52dec'
+ 'aften'
+ 'dcaenc'
+ 'faac'
+ 'faad2'
+ 'fribidi'
+ 'jack'
+ 'lame'
+ 'libass'
+ 'libfdk-aac'
+ 'libmad'
+ 'libmp4v2'
+ 'libdca'
+ 'libpulse'
+ 'libva'
+ 'libvdpau'
+ 'libvpx'
+ 'libvorbis'
+ 'opencore-amr'
+ 'twolame'
+ 'xvidcore'
+ 'x264'
+ 'x265'
+ 'sqlite'
+ 'glu'
+ 'qt5-script'
+ 'qt5-tools'
+ 'qt6-base'
+ 'qt6-tools'
+ 'libxv'
+ 'vapoursynth'
+ 'hicolor-icon-theme'
+ 'setconf'
+)
+source=(
+ 'avidemux::git+https://github.com/mean00/avidemux2.git'
+ 'git+https://github.com/mean00/avidemux2_i18n.git'
+ 'fix_verbose.patch'
+ 'add_settings_pluginui_message_error.patch'
+ 'opus_check.patch'
+ 'fix_mpeg-ts_typo.patch'
+ 'fix_ugly_slider.patch'
+ 'https://github.com/FFmpeg/FFmpeg/commit/effadce6c756247ea8bae32dc13bb3e6f464f0eb.patch'
+)
+sha256sums=(
+ 'SKIP'
+ 'SKIP'
+ '4f751cbb3a65f904f7c0ad68473880e2a9edcda332a293e20ad238280ec52884'
+ 'c5b5d3d7bcdf4c588a780c12fdac7791ddb0527db438c85b4c1c078507da2f0b'
+ 'ae6d2c93163b7b760591688c7811dfdd4a952ed9074d8cbdf4953b701f0fa7db'
+ 'a11452a93c993bdf71f0c29d686badec1c50231bc9d3c6f02f280e06cd8add7a'
+ '3c91ddefadfad5f43d514941ddfa1942ea2c618525aaae36bde5a5d18f8e2067'
+ '206f4d8437b21f6197ffc444c86d0504892a5c2137cb227b4af1c1e8bf2c426c'
+)
+
options=('debug')
pkgver() {
@@ -75,7 +86,11 @@ prepare() {
cd avidemux
git config submodule.i18n.url "${srcdir}/avidemux2_i18n"
- git submodule update --init
+ git -c protocol.file.allow=always submodule update --init \
+ avidemux/qt4/i18n
+
+ # fix build ffmpeg about ASM encode
+ cp "${srcdir}/effadce6c756247ea8bae32dc13bb3e6f464f0eb.patch" avidemux_core/ffmpeg_package/patches/upstream/effadce6c756247ea8bae32dc13bb3e6f464f0eb.patch
# http://avidemux.org/smif/index.php/topic,16301.0.html
patch -p1 -i "${srcdir}/fix_verbose.patch"
@@ -83,6 +98,13 @@ prepare() {
# add SETTINGS to MESSAGE(FATAL_ERROR in avidemux_plugins/CMakeLists.txt
patch -p1 -i "${srcdir}/add_settings_pluginui_message_error.patch"
+ # Fix Typo 'Mpeg TS' -> 'Mpeg-TS'
+ patch -p1 -i "${srcdir}/fix_mpeg-ts_typo.patch"
+
+ # fix ugly slider(?)
+ patch -p1 -i "${srcdir}/fix_ugly_slider.patch"
+
+ # Cosmetic opus check thing
patch --binary -p1 -i "${srcdir}/opus_check.patch"
}
@@ -207,41 +229,49 @@ build() {
package_avidemux-core-git() {
pkgdesc="Core libs for Avidemux. (GIT version)"
- depends=('a52dec'
- 'libaom.so'
- 'aften'
- 'dcaenc'
- 'libfaac.so'
- 'libfaad.so'
- 'fribidi'
- 'jack'
- 'lame'
- 'libass.so'
- 'libfdk-aac.so'
- 'libmad'
- 'libmp4v2'
- 'libdca'
- 'libpulse.so'
- 'libva.so'
- 'libvdpau'
- 'libvpx.so'
- 'libvorbis.so'
- 'libopencore-amrnb.so'
- 'libopencore-amrwb.so'
- 'libtwolame.so'
- 'libxvidcore.so'
- 'libx264.so'
- 'libx265.so'
- )
- optdepends=('avidemux-qt5-git: a Qt5 GUI for Avidemux'
- 'avidemux-qt6-git: a Qt6 GUI for Avidemux'
- 'avidemux-cli-git: a CLI frontend for Avidemux'
- 'wine: AVSload (Load Avisynth scripts on Avidemux)'
- 'vapoursynth: vsProxy (Load Vapoursynth scripts on Avidemux)'
- 'cuda: Nvidia hw encoder'
- 'libva-intel-driver: Intel hw encoder'
- 'libva-mesa-driver: Mesa hw encoder'
- )
+ depends=(
+ 'a52dec' # 'liba52.so'
+ 'alsa-lib' 'libasound.so'
+ 'aom' 'libaom.so'
+ 'aften' # 'libaften.so'
+ 'dcaenc' # 'libdcaenc.so'
+ 'faac' 'libfaac.so'
+ 'faad2' 'libfaad.so'
+ 'gcc-libs' # 'libgcc_s.so' 'libstdc++.so'
+ 'glibc' # 'libc.so' 'libm.so'
+ 'fribidi'
+ 'jack2' 'libjack.so'
+ 'lame' 'libmp3lame.so'
+ 'libass' 'libass.so'
+ 'libfdk-aac' 'libfdk-aac.so'
+ 'libmad' # 'libmad.so'
+ 'libmp4v2' # 'libmp4v2.so'
+ 'libdca' # 'libdca.so'
+ 'libpulse' 'libpulse.so'
+ 'libva' 'libva.so' 'libva-drm.so' 'libva-x11.so'
+ 'libvdpau' 'libvdpau.so'
+ 'libvpx' 'libvpx.so'
+ 'libvorbis' 'libvorbis.so' 'libvorbisenc.so'
+ 'libx11' # 'libX11.so'
+ 'opencore-amr' 'libopencore-amrnb.so' 'libopencore-amrwb.so'
+ 'opus' 'libopus.so'
+ 'sqlite' 'libsqlite3.so'
+ 'twolame' 'libtwolame.so'
+ 'xvidcore' 'libxvidcore.so'
+ 'x264' 'libx264.so'
+ 'x265' 'libx265.so'
+ 'zlib' 'libz.so'
+ )
+ optdepends=(
+ 'avidemux-qt5-git: a Qt5 GUI for Avidemux'
+ 'avidemux-qt6-git: a Qt6 GUI for Avidemux'
+ 'avidemux-cli-git: a CLI frontend for Avidemux'
+ 'wine: AVSload (Load Avisynth scripts on Avidemux)'
+ 'vapoursynth: vsProxy (Load Vapoursynth scripts on Avidemux)'
+ 'cuda: Nvidia hw encoder'
+ 'libva-intel-driver: Intel hw encoder'
+ 'libva-mesa-driver: Mesa hw encoder'
+ )
provides=('avidemux-core')
conflicts=('avidemux-core')
@@ -260,17 +290,25 @@ package_avidemux-core-git() {
package_avidemux-qt5-git() {
pkgdesc="Qt5 GUI for Avidemux. (GIT version)"
- depends=("avidemux-core-git=${pkgver}"
- 'qt5-base'
- 'libxv'
- 'glu'
- 'desktop-file-utils'
- 'hicolor-icon-theme'
- )
+ depends=(
+ "avidemux-core-git=${pkgver}"
+ 'gcc-libs' # 'libgcc_s.so' 'libstdc++.so'
+ 'glibc' # 'libc.so' 'libm.so'
+ 'glu' # 'libGLU.so'
+ 'libglvnd' 'libOpenGL.so'
+ 'libx11' # 'libX11.so'
+ 'libxext' # 'libXext.so'
+ 'libxv' # 'libXv.so'
+ 'qt5-base' # 'libQt5Core.so' 'libQt5Gui.so' 'libQt5Network.so' 'libQt5Widgets.so'
+ 'x264' 'libx264.so'
+ 'x265' 'libx265.so'
+ 'hicolor-icon-theme'
+ )
provides=('avidemux-qt5')
- conflicts=('avidemux-qt5'
- 'avidemux-qt'
- )
+ conflicts=(
+ 'avidemux-qt5'
+ 'avidemux-qt'
+ )
replaces=('avidemux-qt-git')
DESTDIR="${pkgdir}" cmake --install build_qt5
@@ -292,17 +330,25 @@ package_avidemux-qt5-git() {
package_avidemux-qt6-git() {
pkgdesc="Qt6 GUI for Avidemux. (GIT version)"
- depends=("avidemux-core-git=${pkgver}"
- 'qt6-base'
- 'libxv'
- 'glu'
- 'desktop-file-utils'
- 'hicolor-icon-theme'
- )
+ depends=(
+ "avidemux-core-git=${pkgver}"
+ 'gcc-libs' # 'libgcc_s.so' 'libstdc++.so'
+ 'glibc' # 'libc.so' 'libm.so'
+ 'glu' # 'libGLU.so'
+ 'libglvnd' 'libOpenGL.so'
+ 'libx11' # 'libX11.so'
+ 'libxext' # 'libXext.so'
+ 'libxv' # 'libXv.so'
+ 'qt6-base' # 'libQt6Core.so' 'libQt6Gui.so' 'libQt6Network.so' 'libQt6OpenGL.so' 'libQt6OpenGLWidgets.so' 'libQt6Widgets.so'
+ 'x264' 'libx264.so'
+ 'x265' 'libx265.so'
+ 'hicolor-icon-theme'
+ )
provides=('avidemux-qt6')
- conflicts=('avidemux-qt6'
- 'avidemux-qt'
- )
+ conflicts=(
+ 'avidemux-qt6'
+ 'avidemux-qt'
+ )
DESTDIR="${pkgdir}" cmake --install build_qt6
DESTDIR="${pkgdir}" cmake --install build_qt6_plugins
@@ -326,7 +372,11 @@ package_avidemux-qt6-git() {
package_avidemux-cli-git() {
pkgdesc="CLI frontend for Avidemux. (GIT version)"
- depends=("avidemux-core-git=${pkgver}")
+ depends=(
+ "avidemux-core-git=${pkgver}"
+ 'gcc-libs' # 'libgcc_s.so' 'libstdc++.so'
+ 'glibc' # 'libc.so' 'libm.so'
+ )
provides=('avidemux-cli')
conflicts=('avidemux-cli')