summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsL1pKn072021-01-09 07:38:34 +0100
committersL1pKn072021-01-09 07:38:34 +0100
commite9c6686db7e88ba3782190ca0a7ec2d109ebfd6d (patch)
treec6dfe7b687207a1135857be6c9cfb82bcc3a950c /PKGBUILD
downloadaur-e9c6686db7e88ba3782190ca0a7ec2d109ebfd6d.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..25af061c0f38
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=removedirt
+pkgname=avisynth-plugin-${_plug}-git
+pkgver=v0.9.2.26.g2952af0
+pkgrel=1
+pkgdesc="Plugin for Avisynth: ${_plug} (GIT version)"
+arch=('x86_64')
+url='https://github.com/pinterf/RemoveDirt'
+license=('GPL')
+depends=('avisynthplus')
+makedepends=('git'
+ 'cmake'
+ )
+provides=("avisynth-plugin-${_plug}")
+conflicts=("avisynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/pinterf/RemoveDirt.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+
+ cmake "../${_plug}" \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+
+ make
+}
+
+package(){
+ make -C build DESTDIR="${pkgdir}" install
+
+ install -Dm644 "${_plug}/RemoveDirt/documentation/RemoveDirt.htm" "${pkgdir}/usr/share/doc/avisynth/plugins/${_plug}/RemoveDirt.htm"
+}