summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsL1pKn072023-01-23 00:03:28 +0100
committersL1pKn072023-01-23 00:03:28 +0100
commit593e9d7cca4a651c7c409d8d04fec0acae266488 (patch)
tree91aab05e7ed01c613d919616d636569bd5b07cc9 /PKGBUILD
parent127db062b49336e2636e99a283b4aeff032a603d (diff)
downloadaur-593e9d7cca4a651c7c409d8d04fec0acae266488.tar.gz
bump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 11 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e59796d8e16b..19800e5a54b5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,42 +2,41 @@
_plug=rgtools
pkgname=avisynth-plugin-${_plug}-git
-pkgver=1.1.0.g1311d1c
+pkgver=1.2.0.ga9cff29
pkgrel=1
pkgdesc="Plugin for Avisynth: ${_plug} (GIT version)"
arch=('x86_64')
url='https://github.com/pinterf/RgTools'
license=('MIT')
-depends=('avisynthplus')
+depends=('libavisynth.so')
makedepends=('git'
'cmake'
+ 'avisynthplus'
)
provides=("avisynth-plugin-${_plug}")
conflicts=("avisynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/pinterf/RgTools.git")
sha256sums=('SKIP')
+options=('debug')
pkgver() {
cd "${_plug}"
echo "$(git describe --long --tags | tr - .)"
}
-prepare() {
- mkdir -p build
-}
-
build() {
- cd build
- cmake "../${_plug}" \
- -DCMAKE_BUILD_TYPE=None \
- -DCMAKE_INSTALL_PREFIX=/usr \
+ CXXFLAGS=" $(pkg-config --cflags avisynth)"
+
+ cmake -S "${_plug}" -B build \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr
- make
+ cmake --build build
}
package(){
- make -C build DESTDIR="${pkgdir}" install
+ DESTDIR="${pkgdir}" cmake --install build
install -Dm644 "${_plug}/README.md" "${pkgdir}/usr/share/doc/${_plug}/README.md"
install -Dm644 "${_plug}/RgTools/documentation/RgTools.txt" "${pkgdir}/usr/share/doc/${_plug}/RgTools.txt"