summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsL1pKn072023-01-23 00:56:23 +0100
committersL1pKn072023-01-23 00:56:23 +0100
commit02023c2dcff78a7142fe4a0e8e09d6b286639931 (patch)
tree1cd9c24b46d2173c5caaf92dc766c8ad3d679240 /PKGBUILD
parent1e1ddd70324d63d7c1095027b5ea6e6be4b73d77 (diff)
downloadaur-avisynth-plugin-turnstile-git.tar.gz
bump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 12 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cd299fd5e2ea..e105615855ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_plug=turnstile
pkgname=avisynth-plugin-${_plug}-git
-pkgver=v1.0.0.0.g9174d07
+pkgver=1.0.0.0.g9174d07
pkgrel=1
pkgdesc="Plugin for Avisynth: ${_plug} (GIT version)"
arch=('x86_64')
@@ -25,30 +25,32 @@ sha256sums=('SKIP'
pkgver() {
cd "${_plug}"
- echo "$(git describe --long --tags | tr - .)"
+ echo "$(git describe --long --tags | tr - . | tr -d v)"
}
prepare() {
- mkdir -p build
-
cd "${_plug}"
patch -p1 -i "${srcdir}/esee"
+ sed 's|8_H|9_H|g' \
+ -i CMakeLists.txt
git config submodule.include/lodepng.url "${srcdir}/lodepng"
- git submodule update --init include/lodepng
+ git -c protocol.file.allow=always submodule update --init \
+ include/lodepng
}
build() {
- cd build
+ CXXFLAGS=" $(pkg-config --cflags avisynth)"
- cmake "../${_plug}" \
+ cmake -S "${_plug}" -B build \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DAVISYNTHPLUS_HDR=/usr/include/avisynth/avisynth.h
+ -DAVISYNTHPLUS_HDR=/usr/include/avisynth/avisynth.h \
+ -DTURNSTILE_TESTS=OFF
- make
+ cmake --build build
}
package(){
- make -C build DESTDIR="${pkgdir}" install
+ DESTDIR="${pkgdir}" cmake --install build
}