summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarl Smedstad2024-01-15 23:21:30 +0100
committerCarl Smedstad2024-01-15 23:24:30 +0100
commit5630b784687edced27dbfc5c2d341210c2a11772 (patch)
tree5a432055eb02a5c220d4cfac5d95b772be9de153 /PKGBUILD
parent05018727e9e93ba90c8bda1557fd33e901bf6368 (diff)
downloadaur-5630b784687edced27dbfc5c2d341210c2a11772.tar.gz
upgpkg: avizo 1.2.1-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 21 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7889beabd38c..69fbb02c27c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,47 +3,48 @@
pkgname=avizo
pkgver=1.2.1
-pkgrel=1
+pkgrel=2
pkgdesc="A neat notification daemon"
-arch=('x86_64')
url="https://github.com/misterdanb/avizo"
-license=('GPL')
+arch=(x86_64)
+license=(GPL-3.0-only)
depends=(
- 'alsa-utils'
- 'dbus'
- 'gobject-introspection'
- 'gtk-layer-shell'
- 'gtk3'
+ alsa-utils
+ cairo
+ dbus
+ glib2
+ glibc
+ gobject-introspection
+ gtk-layer-shell
+ gtk3
+)
+makedepends=(
+ meson
+ ninja
+ vala
)
optdepends=(
'brightnessctl: for helper script lightctl'
'light: for helper script lightctl'
'pamixer: for helper script volumectl'
)
-makedepends=(
- 'vala'
- 'meson'
- 'ninja'
-)
source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/$pkgver.tar.gz")
sha256sums=('efd4763db7c802d22e8939dac909d4886f5967aefbfc3fd526735da2a814b91b')
+_archive="$pkgname-$pkgver"
+
build() {
- cd $pkgname-$pkgver
+ cd "$_archive"
arch-meson . build
meson compile -C build
}
-check() {
- cd $pkgname-$pkgver
-
- meson test -C build
-}
+# No tests available.
package() {
- cd $pkgname-$pkgver
+ cd "$_archive"
meson install -C build --destdir "$pkgdir"
}