summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlex Henrie2021-11-04 20:36:59 -0600
committerAlex Henrie2021-11-04 20:36:59 -0600
commit4d6c6548117c063e363a26b1a5a52c5d21d80bbf (patch)
treec9639501e23bcf42e4049db56b9b20915c965bfd /PKGBUILD
downloadaur-4d6c6548117c063e363a26b1a5a52c5d21d80bbf.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c7f650d421bd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Alex Henrie <alexhenrie24@gmail.com>
+pkgname=avml
+pkgver=0.3.0
+pkgrel=1
+pkgdesc='A portable volatile memory acquisition tool for Linux'
+arch=('x86_64')
+url='https://github.com/microsoft/avml'
+license=('MIT')
+makedepends=('musl' 'rust-musl')
+source=("https://github.com/microsoft/avml/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('e9ae6f99c5278b7acf732e85753e9befcd76937e2343cd8785e096ed03ffe8d2')
+
+build() {
+ cd "$pkgname-$pkgver"
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --frozen --release --all-features --target $CARCH-unknown-linux-musl
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ find target/$CARCH-unknown-linux-musl/release \
+ -maxdepth 1 \
+ -executable \
+ -type f \
+ -exec install -Dm0755 -t "$pkgdir/usr/bin/" {} +
+}