summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEric Berquist2018-09-06 21:13:14 -0400
committerEric Berquist2018-09-06 21:13:14 -0400
commit0e858a9b748213314b0d47c79eed971b1fb19095 (patch)
tree4ba7635318e90cfcb59f3758bb3a1a4bf1a2aaa8 /PKGBUILD
parentb9466a34f0077f047965e98b43f9584372eafccf (diff)
downloadaur-0e858a9b748213314b0d47c79eed971b1fb19095.tar.gz
Force git version of libmsym, jsoncpp no longer installed
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 4 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f6f64803531c..920dc810e488 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
_pkgname=avogadrolibs
pkgname="${_pkgname}-git"
-pkgver=1.90.0.r1455.65b22f8
+pkgver=1.91.0.r1674.207b959f
pkgrel=1
pkgdesc="Avogadro 2: libraries"
url="http://openchemistry.org/projects/avogadro2"
-arch=("i686" "x86_64")
+arch=("x86_64")
license=("Kitware")
-depends=("libarchive" "glew" "hdf5" "vtk" "libmsym" "spglib" "qt5-webview" "qt5-x11extras" "molequeue" "python" "pybind11")
+depends=("libarchive" "glew" "hdf5" "vtk" "libmsym-git" "spglib" "qt5-webview" "qt5-x11extras" "molequeue" "python" "pybind11")
# gdal is for proj, which is optional for VTK but required here? same for openmpi
makedepends=("git" "cmake" "eigen" "gtest" "gdal" "openmpi")
conflicts=("${_pkgname}")
@@ -32,14 +32,9 @@ build() {
-DCMAKE_INSTALL_LIBDIR:PATH=lib \
-DBUILD_SHARED_LIBS:BOOL=ON \
-DENABLE_TESTING:BOOL=ON \
- -DUSE_OPENGL:BOOL=ON \
-DUSE_HDF5:BOOL=ON \
- -DUSE_QT:BOOL=ON \
-DUSE_VTK:BOOL=ON \
- -DUSE_LIBMSYM:BOOL=ON \
- -DUSE_LIBSPG:BOOL=ON \
- -DUSE_PROTOCALL:BOOL=OFF \
- -DUSE_MOLEQUEUE:BOOL=ON \
+ -DUSE_MMTF:BOOK=OFF \
-DUSE_PYTHON:BOOL=ON \
-DPYTHON_EXECUTABLE:PATH=/usr/bin/python \
.
@@ -55,6 +50,4 @@ package() {
cd "${srcdir}/${_pkgname}"
make DESTDIR="${pkgdir}" install
install -D -m 644 LICENSE "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
- # Don't install bundled jsoncpp
- rm "${pkgdir}/usr/lib/libjsoncpp.a"
}